Bug 1227997 - [abrt] cinnamon: __init__.py:76:require_version:ValueError: Namespace Keybinder not available
Summary: [abrt] cinnamon: __init__.py:76:require_version:ValueError: Namespace Keybind...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:aa2202a06723fbea7967b77174d...
: 1228946 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-04 03:43 UTC by leandercarey
Modified: 2015-06-28 20:36 UTC (History)
13 users (show)

Fixed In Version: cinnamon-translations-2.6.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-09 15:03:43 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (566 bytes, text/plain)
2015-06-04 03:43 UTC, leandercarey
no flags Details
File: environ (1.38 KB, text/plain)
2015-06-04 03:43 UTC, leandercarey
no flags Details

Description leandercarey 2015-06-04 03:43:10 UTC
Description of problem:
Occurred on 1st login from cold start after Cinnamon upgrade

Version-Release number of selected component:
cinnamon-2.6.6-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python2 /usr/bin/cinnamon-killer-daemon
dso_list:       pygobject3-base-3.10.2-1.fc20.x86_64
executable:     /usr/bin/cinnamon-killer-daemon
kernel:         4.0.4-101.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
__init__.py:76:require_version:ValueError: Namespace Keybinder not available

Traceback (most recent call last):
  File "/usr/bin/cinnamon-killer-daemon", line 5, in <module>
    gi.require_version('Keybinder', '3.0')
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 76, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Keybinder not available

Local variables in innermost frame:
available_versions: []
version: '3.0'
namespace: 'Keybinder'
repository: <gi.Repository object at 0x7f7a09cb0438>

Comment 1 leandercarey 2015-06-04 03:43:13 UTC
Created attachment 1034552 [details]
File: backtrace

Comment 2 leandercarey 2015-06-04 03:43:14 UTC
Created attachment 1034553 [details]
File: environ

Comment 3 Darth Vader 2015-06-06 10:15:47 UTC
reproducible in f20 VM.

Comment 4 leigh scott 2015-06-06 11:50:47 UTC
does this help?


yum install keybinder3

Comment 5 Fedora Update System 2015-06-06 12:34:26 UTC
cinnamon-2.6.7-2.fc22, nemo-extensions-2.6.x-1.fc22, cinnamon-translations-2.6.2-1.fc22, cinnamon-control-center-2.6.0-3.fc22, cinnamon-screensaver-2.6.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/nemo-extensions-2.6.x-1.fc22,cinnamon-translations-2.6.2-1.fc22,cinnamon-screensaver-2.6.3-2.fc22,cinnamon-control-center-2.6.0-3.fc22,cinnamon-2.6.7-2.fc22

Comment 6 Fedora Update System 2015-06-06 12:34:58 UTC
cinnamon-translations-2.6.2-1.fc20, cinnamon-screensaver-2.6.3-2.fc20, nemo-extensions-2.6.x-1.fc20, cinnamon-control-center-2.6.0-3.fc20, cinnamon-2.6.7-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nemo-extensions-2.6.x-1.fc20,cinnamon-translations-2.6.2-1.fc20,cinnamon-screensaver-2.6.3-2.fc20,cinnamon-control-center-2.6.0-3.fc20,cinnamon-2.6.7-2.fc20

Comment 7 Fedora Update System 2015-06-06 12:37:39 UTC
cinnamon-translations-2.6.2-1.fc21, cinnamon-screensaver-2.6.3-2.fc21, cinnamon-control-center-2.6.0-3.fc21, nemo-extensions-2.6.x-1.fc21, cinnamon-2.6.7-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/nemo-extensions-2.6.x-1.fc21,cinnamon-translations-2.6.2-1.fc21,cinnamon-screensaver-2.6.3-2.fc21,cinnamon-control-center-2.6.0-3.fc21,cinnamon-2.6.7-2.fc21

Comment 8 leigh scott 2015-06-07 06:17:40 UTC
*** Bug 1228946 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2015-06-07 16:02:22 UTC
Package cinnamon-2.6.7-2.fc22, nemo-extensions-2.6.x-1.fc22, cinnamon-translations-2.6.2-1.fc22, cinnamon-control-center-2.6.0-3.fc22, cinnamon-screensaver-2.6.3-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-2.6.7-2.fc22 nemo-extensions-2.6.x-1.fc22 cinnamon-translations-2.6.2-1.fc22 cinnamon-control-center-2.6.0-3.fc22 cinnamon-screensaver-2.6.3-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9595/nemo-extensions-2.6.x-1.fc22,cinnamon-translations-2.6.2-1.fc22,cinnamon-screensaver-2.6.3-2.fc22,cinnamon-control-center-2.6.0-3.fc22,cinnamon-2.6.7-2.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-06-09 15:03:43 UTC
cinnamon-translations-2.6.2-1.fc21, cinnamon-screensaver-2.6.3-2.fc21, cinnamon-control-center-2.6.0-3.fc21, nemo-extensions-2.6.x-1.fc21, cinnamon-2.6.7-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-06-09 15:05:04 UTC
cinnamon-2.6.7-2.fc22, nemo-extensions-2.6.x-1.fc22, cinnamon-translations-2.6.2-1.fc22, cinnamon-control-center-2.6.0-3.fc22, cinnamon-screensaver-2.6.3-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-06-09 15:17:24 UTC
cinnamon-translations-2.6.2-1.fc20, cinnamon-screensaver-2.6.3-2.fc20, nemo-extensions-2.6.x-1.fc20, cinnamon-control-center-2.6.0-3.fc20, cinnamon-2.6.7-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 bcox82 2015-06-09 16:00:18 UTC
It would be nice if the emails announcing availability were sent out after the updates were actually in the repository, e.g.:

Password: 
Last login: Mon Jun  8 08:59:11 PDT 2015 on pts/1
[root@bcox-dualboot ~]# yum update cinnamon-2.6.7-2.fc22
Yum command has been deprecated, redirecting to '/usr/bin/dnf update cinnamon-2.6.7-2.fc22'.
See 'man dnf' and 'man yum2dnf' for more information.
To transfer transaction metadata from yum to DNF, run:
'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'

Failed to synchronize cache for repo 'pgdg94' from 'http://yum.postgresql.org/9.4/fedora/fedora-22-x86_64': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Last metadata expiration check performed 0:13:18 ago on Tue Jun  9 08:46:08 2015.
Dependencies resolved.
Nothing to do.
Complete!
[root@bcox-dualboot ~]#

Comment 14 Neil 2015-06-09 16:16:27 UTC
Same here, tbh I haven't been available to test many fixes not only from cinnamon, seems like a DNF problem.

Comment 15 stasi 2015-06-09 16:19:47 UTC
(In reply to bcox82 from comment #13)
> It would be nice if the emails announcing availability were sent out after
> the updates were actually in the repository, e.g.:
> 
> Password: 
> Last login: Mon Jun  8 08:59:11 PDT 2015 on pts/1
> [root@bcox-dualboot ~]# yum update cinnamon-2.6.7-2.fc22
> Yum command has been deprecated, redirecting to '/usr/bin/dnf update
> cinnamon-2.6.7-2.fc22'.
> See 'man dnf' and 'man yum2dnf' for more information.
> To transfer transaction metadata from yum to DNF, run:
> 'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'
> 
> Failed to synchronize cache for repo 'pgdg94' from
> 'http://yum.postgresql.org/9.4/fedora/fedora-22-x86_64': Cannot download
> repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried,
> disabling.
> Last metadata expiration check performed 0:13:18 ago on Tue Jun  9 08:46:08
> 2015.
> Dependencies resolved.
> Nothing to do.
> Complete!
> [root@bcox-dualboot ~]#

What is so diffcult to follow the links and download/install the package by hand?
Instead of sitting and waiting in front of a broken box.
This is linux.

Comment 16 Michael Schwendt 2015-06-09 16:50:42 UTC
bcox82@sbcglobal.net :

That only shows that you are not familiar with the process yet. There are _multiple_ notifications. The first one only tells that an update ticket in the Fedora Updates System (bodhi) has been submitted (a link to the builds is included in that ticket in case you want to download them from the build system manually). Another notification will tell when the packages have been pushed to the repository. And even then mirror propagation times need to be considered.


Note You need to log in before you can comment on or make changes to this bug.