Bug 122802 - Authconfig fails to join domain (/usr/bin/net)
Authconfig fails to join domain (/usr/bin/net)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 04:13 EDT by Dan Hulme
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.6.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 17:20:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hulme 2004-05-08 04:13:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I have found two problems with Winbind support on Core 2 Test 3, which
I was able to solve, eventually.  As far as I can tell, however,
winbind support is not currently working out of the "box".


Problem 1:

Authentication Configuration depends on /usr/bin/net, which is not
necessarily installed, but no error is shown if it is not.  When
running from a terminal, it becomes apparent that the binary is missing.

To fix this problem, in did "yum install samba-client" which will
install /usr/bin/net.

Problem 2:

The syntax is apparently wrong for the domain join command.  Something
like the following is done:

[/usr/bin/net domain join -w <domain> -S <server> -U Administrator]

This command simply lists the domain controllers.  I did a "man net"
and didn't find anything on the "net domain" command, but apparently
this is what it does.  Once you remove the "domain" word, joining the
domain works fine (of course I had to do it manually).

Once I did these two things I had joined the domain and winbind worked
as expected.


Version-Release number of selected component (if applicable):
authconfig-gtk 4.6.2

How reproducible:
Always

Steps to Reproduce:
1. Open terminal
2. # /usr/bin/system-config-authentication
3. Click on "Configure Winbind"
4. Enter information for a valid domain
    

Actual Results:  a. See that the output does not join a domain, but
only lists domain servers.

b. Or, if samba-client not installed, see:
"sh: line 1: /usr/bin/net: No such file or directory" 



Expected Results:  Should join the domain.  If /usr/bin/net not
available, should report that samba-client must be installed, or
/usr/bin/net should be part of the base install.

Additional info:
Comment 1 Nalin Dahyabhai 2004-05-11 17:20:23 EDT
Hmm. Looks like newer "net" doesn't need to be told which protocol to
use.  Fixing both problems for 4.6.3.
Comment 2 Dan Hulme 2004-05-24 23:49:57 EDT
Too bad 4.6.3 didn't make it into Fedora Core 2 release.  Now the
release has broken domain support :(.

Note You need to log in before you can comment on or make changes to this bug.