Bug 122804 - System unbootable when /boot is a RAID-1
System unbootable when /boot is a RAID-1
Status: CLOSED DUPLICATE of bug 114690
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 04:29 EDT by H. Peter Anvin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 14:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2004-05-08 04:29:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20040105

Description of problem:
Anaconda no longer has an option to install LILO rather than GRUB. 
This is completely disastrous when /boot is a RAID-1, which is
otherwise a highly desirable configuration, since it means any drive
can boot the system.

Anaconda will allow you to make /boot a RAID-1, and will offer to
install GRUB on it.  It produces a completely unusable GRUB
configuration which ends with dropping you into the level 2 GRUB shell.

As far as I can tell, there *is no way to make GRUB operate correctly
on a RAID-1 /boot*.

Version-Release number of selected component (if applicable):
FC2test3 ISO CD

How reproducible:
Always

Steps to Reproduce:
1. Install a system with /boot on a RAID-1
    

Actual Results:  GRUB loads and drops you into the level 2 GRUB shell.

Expected Results:  System boots.

Additional info:

LILO handles this correctly, but there is no longer a way to install
LILO at install time.
Comment 1 Peter Jones 2005-03-14 14:30:48 EST

*** This bug has been marked as a duplicate of 114690 ***

Note You need to log in before you can comment on or make changes to this bug.