Bug 1228112 - tiering:glusterd crashed when trying to detach-tier commit force on a non-tiered volume.
Summary: tiering:glusterd crashed when trying to detach-tier commit force on a non-tie...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1229274 1230563 1260923
TreeView+ depends on / blocked
 
Reported: 2015-06-04 08:53 UTC by Mohammed Rafi KC
Modified: 2016-06-16 13:08 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1229274 1230563 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:08:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-06-04 08:53:04 UTC
Description of problem:

glusterd crashed when trying to detach-tier commit force on a non-tiered volume.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.create a regular volume of any time other than tier
2.start the volume
3.gluster volume detach-tier vol commit force

Actual results:

glusterd crashed

Expected results:

should throw an error.

Additional info:

Comment 1 Anand Avati 2015-06-04 08:57:57 UTC
REVIEW: http://review.gluster.org/11081 (glusterd/tier: glusterd crashed with detach-tier commit force) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Nagaprasad Sathyanarayana 2015-10-25 14:57:02 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 3 Niels de Vos 2016-06-16 13:08:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.