Bug 1228160 - linux untar hanged after the bricks are up in a 8+4 config
Summary: linux untar hanged after the bricks are up in a 8+4 config
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1227649 1227654
Blocks: 1223636
TreeView+ depends on / blocked
 
Reported: 2015-06-04 10:22 UTC by Pranith Kumar K
Modified: 2015-06-20 09:49 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1227654
Environment:
Last Closed: 2015-06-20 09:49:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-04 10:31:34 UTC
REVIEW: http://review.gluster.org/11084 (cluster/ec: EC_XATTR_DIRTY doesn't come in response) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-06-04 11:02:43 UTC
REVIEW: http://review.gluster.org/11084 (cluster/ec: EC_XATTR_DIRTY doesn't come in response) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2015-06-07 05:36:31 UTC
COMMIT: http://review.gluster.org/11084 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 6fce83e55c2a4b96de8c9b1ce5b1bc8a60eaacc3
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Jun 4 09:52:51 2015 +0530

    cluster/ec: EC_XATTR_DIRTY doesn't come in response
    
             Backport of http://review.gluster.com/11078
    
    Problem:
    ec_update_size_version expects all the keys it did xattrop with to come in
    response so that it can set the values again in ec_update_size_version_done.
    But EC_XATTR_DIRTY is not combined so the value won't be present in the
    response. So ctx->post/pre_dirty are not updated in
    ec_update_size_version_done. So these values are still non-zero. When
    ec_unlock_now is called as part of flush's unlock phase it again tries to
    perform same xattrop for EC_XATTR_DIRTY. But ec_update_size_version is not
    expected to be called in unlock phase of flush because ec_flush_size_version
    should have reset everything to zero and unlock is never invoked from
    ec_update_size_version_done for flush/fsync/fsyncdir. This leads to stale lock
    which leads to hang.
    
    Fix:
    EC_XATTR_DIRTY is removed in ex_xattrop_cbk and is never combined with other
    answers. So remove handling of this in the response.
    
    BUG: 1228160
    Change-Id: I657efca6e706e7acb541f98f526943f67562da9f
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11084
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 4 Niels de Vos 2015-06-20 09:49:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.