Bug 122819 - Sendmail with SMTP Authinfo
Sendmail with SMTP Authinfo
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 13:09 EDT by Chan Min Wai
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 08:47:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chan Min Wai 2004-05-08 13:09:24 EDT
Description of Enhancement:
When Sendmail run with SMARTHOST or MAILHUB, there are somehow a
requirement for them to auth to the smtp server they are connecting.

This few line of code should be in the In the sendmail.mc and
Makefiles so that they can be configure easily.

Version-Release number of selected component (if applicable):
Sendmail 8.12.x
Comment 1 Chan Min Wai 2004-05-08 13:14:48 EDT
Sorry this is not a patch, just 2 line of code

for /etc/mail/sendmail.mc Add 
dnl FEATURE(`virtusertable',`hash -o /etc/mail/virtusertable.db')dnl

for /etc/mail/Makefile @ line 10 
POSSIBLE += $(shell test -f authinfo      && echo authinfo.db)

Add one more files /etc/mail/authinfo.README writting how the authinfo
should be written 
AuthInfo:smtp.servername.or.ip "U:username" "P:password" "M:LOGIN" 

For M:LOGIN is the auth method.

Comment 2 Leonard den Ottolander 2004-05-08 14:58:40 EDT
This looks like a "fix" that might be useful to 1 in 10 users, but
would require the other 9 to comment out these options. Rather counter
productive.

I would say WONTFIX.
Comment 3 Leonard den Ottolander 2004-05-08 15:08:04 EDT
Hm. Maybe my conclusion was too hasty. I oversaw this FEATURE is
actually commented out. Still I am not sure if adding this is a big
advantage.
Comment 4 Chan Min Wai 2004-05-09 14:30:46 EDT
Time for a Vote?
I think there might be a need for some Vote to happen for which bug to
be addin :)

But no hard for add them, As Adsl line is getting cheaper and not
everyong is getting an static ip, mail sending will have to pass
through the isp mail server somehow. So it is an advance to addin.

Thank You
Comment 5 Alexander Dalloz 2004-05-10 07:10:18 EDT
Why the extra authinfo directive in sendmail.mc and an extra file? The
AuthInfo data can go to the access file as well. Users should only
care that then /etc/mail/access* should have chmod 640.
Comment 6 Chan Min Wai 2004-05-10 08:49:01 EDT
This authinfo IS NOT for USERS but for the Sendmail server which will
be connecting to a MAIL_HUB OR SMART_HOST (In other words, SMTP Server
on the ISP/Co-Office) .

But they will be a requirement to auth before sending mail.
And this is why this Exists.
Comment 7 Chan Min Wai 2004-05-18 05:15:43 EDT
leonard: Any Good news about this?
Comment 8 Leonard den Ottolander 2004-05-18 08:13:40 EDT
Chan: It's not my bug. But if you want to know, I don't feel very
strongly either way. Adding it wouldn't hurt, but not adding it
wouldn't either. When you are setting up a mail server you should be
studying the docs anyway, so having one more config option predefined
in sendmail.mc shouldn't make a big difference.
Comment 9 Thomas Woerner 2004-06-14 08:17:20 EDT
This is not a standard configuration and btw. is easy to set up.

Closing as 'not a bug'.
Comment 10 Rodolfo J. Paiz 2004-07-10 18:29:04 EDT
You're right, Thomas... it's not a bug. However, I think it's a valid 
RFE. More and more people are having need of AUTHINFO as ISP's start 
to require SMTP AUTH (which is in itself a good thing).

So perhaps the way to solve it is just to add two or three lines of 
text to /etc/mail/access showing how to set it up quickly? Likely it 
will help more and more users over time.

Note You need to log in before you can comment on or make changes to this bug.