Bug 1228216 - Disperse volume: gluster volume status doesn't show shd status
Summary: Disperse volume: gluster volume status doesn't show shd status
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1217311
Blocks: qe_tracker_everglades 1224195
TreeView+ depends on / blocked
 
Reported: 2015-06-04 12:25 UTC by Ashish Pandey
Modified: 2015-09-09 09:37 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1217311
Environment:
Last Closed: 2015-09-09 09:37:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-04 12:25:54 UTC
REVIEW: http://review.gluster.org/10994 (Added support to get status of Self Heal Daemon  for disperse volume. ("gluster volume status")) posted (#3) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)

Comment 2 Anand Avati 2015-06-10 13:24:46 UTC
REVIEW: http://review.gluster.org/10994 (glusterd : Display status of Self Heal Daemon for disperse volume) posted (#5) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)

Comment 3 Anand Avati 2015-08-25 17:59:54 UTC
COMMIT: http://review.gluster.org/10994 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 8914210f25a976b9a1973fbf8c2ced1b307e807f
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Wed May 13 14:48:42 2015 +0530

    glusterd : Display status of Self Heal Daemon for disperse volume
    
     Problem : Status of Self Heal Daemon is not
     displayed in "gluster volume status"
    
     Fix : As disperse volumes are self heal compatible,
     show the status of self heal daemon in gluster
     volume status command
    
    Change-Id: I83d3e6a2fd122b171f15cfd76ce8e6b6e00f92e2
    BUG: 1228216
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/10994
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 4 Kaushal 2015-09-09 09:37:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.