This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 122826 - fsck on startup fails if no root entry present in /etc/fstab
fsck on startup fails if no root entry present in /etc/fstab
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: basesystem (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 15:29 EDT by Mike Hearn
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 14:41:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Hearn 2004-05-08 15:29:20 EDT
Apologies if this is the wrong component, I was not sure where to file
it. If the line for the root filesystem is missing in /etc/fstab then
bootup will fail apparently due to fsck being passed "/" as an
argument rather than a device. This prints an uber-scary message about
the superblock being toasted and drops you into a recovery console.

I have no clue how my machine got into the state where it was missing
this entry. I did an an unclean shutdown but it's a rather odd
"corruption" to get :)
Comment 1 Bill Nottingham 2004-05-21 14:41:20 EDT
If you look at /proc/mounts, you'll have:

[notting@nostromo: ~]$ cat /proc/mounts
...
/dev/root / ext3 rw,noatime 0 0
...

Hence, it's a bit more code to dig out the root device name.

Probably won't fix this at this point.

Note You need to log in before you can comment on or make changes to this bug.