Bug 1228273 - Subscription Details page is confusing in a multi-org context; should clear when switching between orgs
Summary: Subscription Details page is confusing in a multi-org context; should clear w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Uncategorized
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-04 14:09 UTC by Corey Welton
Modified: 2019-09-25 21:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:52:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14108 None None None 2016-04-22 16:13:56 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Corey Welton 2015-06-04 14:09:34 UTC
Description of problem:
When a user is viewing subscription details and then switches orgs, the subscriptions list on the left hand side changes accordingly, but the main view remains, showing details for the previously viewed subscription

Version-Release number of selected component (if applicable):
Compose 7

How reproducible:


Steps to Reproduce:
1.  Create two different orgs and import significantly different manifests into each.
2.  While context is set to Org1, Go to Content > Red Hat Subscriptions
3.  View details for one of the subscriptions ("x out of unlimited" or "x out of y", etc.)
4. While viewing subscription details, choose a different org from the context picker in the top left corner.
5.  View results

Actual results:
The left pane changes correctly, properly showing the subscriptions for the selected Org.  However, the Details window remains open, pointing to the previous subscription user was looking at before.

Expected results:
This is incredibly confusing; we shouldn't be seeing details irrelevant to an org after switching to it.  Yes, there are workarounds -- simply hitting the close button on the Content Details, or by selecting a new subscription from the left pane. 

Regardless, this (the subscription details view) should probably be cleared/deselected when switching org contexts.  

Additional info:

Comment 2 Walden Raines 2016-03-08 19:49:02 UTC
Created redmine issue http://projects.theforeman.org/issues/14108 from this bug

Comment 3 Walden Raines 2016-03-08 20:43:48 UTC
PR: https://github.com/Katello/bastion/pull/100

Comment 4 Bryan Kearney 2016-03-08 21:00:56 UTC
Upstream bug component is Uncategorized

Comment 5 Bryan Kearney 2016-03-09 01:01:03 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14108 has been closed
-------------
Walden Raines
Applied in changeset commit:bastion|d02f043727370728e77c1d240a583e1759baef0a.

Comment 6 jcallaha 2016-03-24 20:30:54 UTC
Verified in Satellite 6.2 Beta Snap 5.1. Context now shifts completely when switching orgs.

Comment 9 errata-xmlrpc 2016-07-27 08:52:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.