Bug 1228340 - Home, Network, Root and Trash folders in Places disappeared
Summary: Home, Network, Root and Trash folders in Places disappeared
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-04 16:31 UTC by nucleo
Modified: 2015-06-11 18:39 UTC (History)
11 users (show)

Fixed In Version: kdelibs-4.14.9-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-11 18:39:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 345174 None None None Never

Description nucleo 2015-06-04 16:31:35 UTC
Description of problem:
After updating kdelibs disappeared Home, Network, Root and Trash folders in Places in file open dialog.


Version-Release number of selected component (if applicable):
kdelibs-4.14.8-1.fc21.i686 from https://admin.fedoraproject.org/updates/FEDORA-2015-8922

How reproducible:


Steps to Reproduce:
1. Press "open file" in kwrite
2.
3.

Actual results:
Only disks shown in Places.

Expected results:
Should be shown disks and Home, Network, Root, Trash folders.

Additional info:
Folders shown after downgrading to kdelibs-4.14.7-4.fc21.i686.

Comment 1 Rex Dieter 2015-06-04 16:36:15 UTC
Are you testing with plasma5(copr) or stock kde4 ?  (I was assuming the latter, but asking to be sure)

Comment 2 nucleo 2015-06-04 16:38:29 UTC
No copr, only KDE4 from Fedora 21 repository.

Comment 3 Sergio Monteiro Basto 2015-06-04 16:56:26 UTC
I have the same problem, places of open file dialogue of konqueror and kwrite (at least) doesn't show: Home, Network, Root and Trash folder but show my disks like in Dolphin.
Dolphin places doesn't have this problem, places have: Home, Network, Root and Trash folder .

Comment 4 Sergio Monteiro Basto 2015-06-04 17:14:17 UTC
with Fedora 21, KDE - Platform Version 4.14.8 from updates-testing

Comment 5 Rex Dieter 2015-06-04 17:52:41 UTC
I suspect this may be related to the fix for upstream bug
https://bugs.kde.org/show_bug.cgi?id=345174
removed syncing of content between kplaces/bookmarks.xml and user-places.xbel
(which caused problems for kde4 apps under plasma5)

I'll make a scratch build reverting that commit for you to test.

Comment 6 Rex Dieter 2015-06-04 18:00:12 UTC
Scratch build underway:
https://koji.fedoraproject.org/koji/taskinfo?taskID=9948390

Comment 7 Rex Dieter 2015-06-04 18:36:01 UTC
newer dolphin was also updated to use user-places.xbel instead of kfileplaces/bookmarks.xml too (if we do the revert in kdelibs, we may want to revert the dolphin commit too)

Comment 8 nucleo 2015-06-04 18:39:20 UTC
No problem with scratch build.

Comment 9 Sergio Monteiro Basto 2015-06-04 19:06:46 UTC
I clean cache and reboot the system 

Now I got 3 times the set of Home, Network, Root and Trash folder  , 
I think running dolphin added this places ,  
Because I saw kwrite with one set , after two sets , and now after reboot and run dolphin 3 sets ... 

maybe we should revert dolphin commit too , I don't know .

Comment 10 Rex Dieter 2015-06-04 19:53:37 UTC
That's odd. :-/

So what kdelibs used to do (and current behavior after reverting) is synchronize changes made to 
~/.kde/share/apps/kfileplaces/bookmarks.xml
to (more standardized):
~/.local/share/user-places.xbel

what dolphin *used* to do was use
~/.kde/share/apps/kfileplaces/bookmarks.xml  (exclusively)
but now uses
~/.local/share/user-places.xbel

When things "disappeared", I'm guessing there was content in bookmarks.xml that never got sync'd/migrated to user-places.xbel (for whatever reason)

dolphin doesn't sync anything, so we can consider making modifications there only if dolphin misbehaves in some way ... though.. hrm... except if you add bookmarks there, it'll *only* show there (user-places.xbel) and not any other kde4 apps  :-/

Comment 11 Rex Dieter 2015-06-04 20:04:00 UTC
Here's a link to the upstream commit we've tested reverting,

http://quickgit.kde.org/?p=kdelibs.git&a=commit&h=5c0a31a2f2a46aa44b8c34baae67b6951b2abcaf

In case my analysis was incorrect.

Comment 12 Sergio Monteiro Basto 2015-06-05 00:23:57 UTC
Hi,

mv ~/.kde/share/apps/kfileplaces/bookmarks.xml ~/.local/share/user-places.xbel* . 

fix the problem :) 

I lost my bookmarks, but I can recover them by searching in backuped files 
cat user-places.xbel.bak  | grep title 
cat bookmarks.xml  | grep title  

I got almost 300 entries, so this clean up was cool, no problem .

So scratch build (4.14.8-1.fc21.1) is working without problems .
My tests was not conclusive but looks like scratch build is working better than version from updates-testing.   
kde got cache and to test it properly I need logout session , remove cache "rm -rf /var/tmp/kdecache-sergio" and log in again.

Comment 13 Fedora Update System 2015-06-07 17:33:51 UTC
kdelibs-4.14.9-2.fc21, kdepimlibs-4.14.9-1.fc21, kde-runtime-15.04.2-1.fc21, kde-baseapps-15.04.2-1.fc21, oxygen-icon-theme-15.04.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-8922/kdelibs-4.14.9-2.fc21,kdepimlibs-4.14.9-1.fc21,kde-runtime-15.04.2-1.fc21,kde-baseapps-15.04.2-1.fc21,oxygen-icon-theme-15.04.2-1.fc21

Comment 14 Fedora Update System 2015-06-09 15:00:16 UTC
Package kdelibs-4.14.9-2.fc21, kdepimlibs-4.14.9-1.fc21, kde-runtime-15.04.2-1.fc21, kde-baseapps-15.04.2-1.fc21, oxygen-icon-theme-15.04.2-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdelibs-4.14.9-2.fc21 kdepimlibs-4.14.9-1.fc21 kde-runtime-15.04.2-1.fc21 kde-baseapps-15.04.2-1.fc21 oxygen-icon-theme-15.04.2-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8922/kdelibs-4.14.9-2.fc21,kdepimlibs-4.14.9-1.fc21,kde-runtime-15.04.2-1.fc21,kde-baseapps-15.04.2-1.fc21,oxygen-icon-theme-15.04.2-1.fc21
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2015-06-11 18:39:28 UTC
kdelibs-4.14.9-2.fc21, kdepimlibs-4.14.9-1.fc21, kde-runtime-15.04.2-1.fc21, kde-baseapps-15.04.2-1.fc21, oxygen-icon-theme-15.04.2-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.