Bug 122848 - bridge slave interfaces are probed out of order
Summary: bridge slave interfaces are probed out of order
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-09 05:48 UTC by Andy Lutomirski
Modified: 2014-03-17 02:45 UTC (History)
1 user (show)

Fixed In Version: 7.56-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 19:51:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (284 bytes, patch)
2004-05-09 05:49 UTC, Andy Lutomirski
no flags Details | Diff

Description Andy Lutomirski 2004-05-09 05:48:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040503 Firefox/0.8.0+

Description of problem:
I have two ethernet ports (eth0 and eth1).  eth0 is a slave to br0;
eth1 is not bridged.  Since ifcfg-eth0 contains the directive
BRIDGE=br0, it is brought up late.  The problem is that it gets probed
after eth1, so the modules load out of order and network startup gets
confused.

IMHO the fix is to change the network script to do is_available on
bridge slaves on the first pass.




Version-Release number of selected component (if applicable):
initscripts-7.53-1

How reproducible:
Always

Steps to Reproduce:
1. eth0 and eth1 should use different drivers
2. ifcfg-eth0 has 'BRIDGE=br0'
3. reboot
    

Expected Results:  eth0 should be probed, then eth1 should come up,
then eth0 should come up.

Additional info:

Comment 1 Andy Lutomirski 2004-05-09 05:49:28 UTC
Created attachment 100111 [details]
proposed fix

Comment 2 Bill Nottingham 2004-05-21 19:51:53 UTC
Added, will be in 7.56-1; thanks!


Note You need to log in before you can comment on or make changes to this bug.