Bug 1228521 - USS: Take ref on root inode
Summary: USS: Take ref on root inode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On: 1228520 1245919
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-05 06:30 UTC by Mohammed Rafi KC
Modified: 2015-09-09 09:37 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1228520
Environment:
Last Closed: 2015-09-09 09:37:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-06-05 06:30:12 UTC
+++ This bug was initially created as a clone of Bug #1228520 +++

Description of problem:

<snip from xlators/features/snapview-client/src/snapview-client.c>


       root_loc.gfid[15] = 1;
       root_loc.inode = loc->inode->table->root;
       root_loc.inode->ia_type = IA_IFDIR;
       temp_loc = &root_loc;

</snip>
It is better to take a ref on root inode in above case.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Mohammed Rafi KC on 2015-06-05 02:28:29 EDT ---

upstream patch : http://review.gluster.org/10750

Comment 1 Anand Avati 2015-06-09 10:43:43 UTC
REVIEW: http://review.gluster.org/11094 (uss: Take ref on root inode) posted (#3) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-08-05 08:33:32 UTC
REVIEW: http://review.gluster.org/11094 (uss: Take ref on root inode) posted (#5) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-08-14 06:45:09 UTC
COMMIT: http://review.gluster.org/11094 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 39f2a499c69943dd0430e75276f55262de8c26b4
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon May 11 12:36:33 2015 +0530

    uss: Take ref on root inode
    
    If we recieve a statfs call on snap directory, we will redirect
    the call into the root, by creating a new root loc. So it is better to
    take a ref on the root inode
    (http://review.gluster.org/#/c/10358/5/xlators/features/
    snapview-client/src/snapview-client.c)
    
    
    Back port of :
    >Change-Id: I5649addac442d391b2550346b115dec58fed5b86
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/10750
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    
    Change-Id: Idd575a5313bcbc3d7bfdd954c7bfecce371f3add
    BUG: 1228521
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11094
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 4 Kaushal 2015-09-09 09:37:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.