Bug 1228550 - sapconf should also consider ntp configured via ntp package instead of just Chronyd
Summary: sapconf should also consider ntp configured via ntp package instead of just C...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sapconf   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ngo Than
QA Contact: cluster-qe@redhat.com
Jiri Herrmann
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1018952 1203710 1313485 1289025 1295829
TreeView+ depends on / blocked
 
Reported: 2015-06-05 07:38 UTC by Ranjith Rajaram
Modified: 2016-11-04 02:08 UTC (History)
5 users (show)

Fixed In Version: sapconf-0.98-8
Doc Type: Release Note
Doc Text:
*sapconf* now detects the NTP configuration properly Previously, the *sapconf* utility did not check whether the host system was configured to use the Network Time Protocol (NTP). As a consequence, even when NTP was configured, *sapconf* displayed the following error: 3: NTP Service should be configured and started With this update, *sapconf* properly checks for the NTP configuration, and the described problem no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:08:45 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2273 normal SHIPPED_LIVE sapconf bug fix update 2017-02-07 20:09:01 UTC

Description Ranjith Rajaram 2015-06-05 07:38:51 UTC
Description of problem:

sapconf only check whether chronyd is running or not. It does not check whether the host system is configured to use ntp. 

[root@test ~]# ntpstat 
synchronised to NTP server (X.X.X.X) at stratum 2 
   time correct to within 8108 ms
   polling server every 64 s


[root@test ~]# service ntpd status
Redirecting to /bin/systemctl status  ntpd.service
ntpd.service - Network Time Service
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; disabled)
   Active: active (running) since Fri 2015-06-05 13:04:09 IST; 52s ago
  Process: 20921 ExecStart=/usr/sbin/ntpd -u ntp:ntp $OPTIONS (code=exited, status=0/SUCCESS)
 Main PID: 20922 (ntpd)
   CGroup: /system.slice/ntpd.service
           └─20922 /usr/sbin/ntpd -u ntp:ntp -g

Whenever I run sapconf script, sapconf throws the following message

"3: NTP Service should be configured and started"


Version-Release number of selected component (if applicable):


How reproducible:
sapconf-0.98-6.el7.noarch

Steps to Reproduce:
1. Configure NTP using ntp.conf/ntp package
2. run sapconf script
3.

Actual results:

Sapconf prints the message that NTP is not running


Expected results:

sapconf should also honor ntp configuration made via the ntp package


Additional info:

Comment 13 errata-xmlrpc 2016-11-04 02:08:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2273.html


Note You need to log in before you can comment on or make changes to this bug.