Bug 122862 - NVidia driver compile fails on kernel 2.6.5-1.356 on x86-64
Summary: NVidia driver compile fails on kernel 2.6.5-1.356 on x86-64
Status: CLOSED DUPLICATE of bug 73733
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-09 14:45 UTC by Joerg Skottke
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joerg Skottke 2004-05-09 14:45:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040506

Description of problem:
NVidia compile log (using NVidia AMD64 package)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel;
would you li
   ke the installer to attempt to download a kernel interface for your
kernel f
   rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel;
this means
   that the installer will need to compile a new kernel interface.
ERROR: The kernel header file
       '/lib/modules/2.6.5-1.356/build/include/linux/modversions.h'
does not
       exist.  The most likely reason for this is that the kernel
header files
       in '/lib/modules/2.6.5-1.356/build/include' have not been
configured.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find
suggestions
       on fixing installation problems in the README available on the
Linux
       driver download page at www.nvidia.com.


Version-Release number of selected component (if applicable):
kernel-source 2.6.5-1.356

How reproducible:
Always

Steps to Reproduce:
1. Instal FC2 Test 3
2. Dwonload current AMD-64 driver from NVidia
3. Compile
    

Actual Results:  Error / compile fails

Expected Results:  Working kernel module

Additional info:

Comment 1 Arjan van de Ven 2004-05-09 18:23:36 UTC
bugs in the binary only nvidia kernel module should go to nvidia instead.

*** This bug has been marked as a duplicate of 73733 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:03:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.