Bug 122864 - NVidia driver compile fails on kernel 2.6.5-1.356 on x86-64
NVidia driver compile fails on kernel 2.6.5-1.356 on x86-64
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 10:52 EDT by Joerg Skottke
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joerg Skottke 2004-05-09 10:52:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040506

Description of problem:
NVidia compile log (using NVidia AMD64 package)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel;
would you li
   ke the installer to attempt to download a kernel interface for your
kernel f
   rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel;
this means
   that the installer will need to compile a new kernel interface.
ERROR: The kernel header file
       '/lib/modules/2.6.5-1.356/build/include/linux/modversions.h'
does not
       exist.  The most likely reason for this is that the kernel
header files
       in '/lib/modules/2.6.5-1.356/build/include' have not been
configured.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find
suggestions
       on fixing installation problems in the README available on the
Linux
       driver download page at www.nvidia.com.


Version-Release number of selected component (if applicable):
kernel-source 2.6.5-1.356

How reproducible:
Always

Steps to Reproduce:
1. Instal FC2 Test 3
2. Dwonload current AMD-64 driver from NVidia
3. Compile
    

Actual Results:  Error / compile fails

Expected Results:  Working kernel module

Additional info:
Comment 1 Arjan van de Ven 2004-05-09 14:23:59 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.