Bug 122867 - upsd.users must be readable by user "nut"
upsd.users must be readable by user "nut"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 12:32 EDT by Carlos Rodrigues
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 17:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2004-05-09 12:32:05 EDT
From Bugzilla Helper:
User-Agent: Opera/7.23 (X11; Linux i686; U)  [en]

Description of problem:
I'm using a rebuilt nut-2.0.0-1.src.rpm from FC2 Test3 on Fedora Core 
1 (I maintain a driver outside of nut's tree and I'm porting it to 2.
0.0) and I noticed a problem with the files in /etc/ups.
The problem is in the upsd.users file. Its permissions are:

-rw-------   1 root root   2371 May  9 17:05 upsd.users

when they should be:

-rw-r-----   1 root nut   2371 May  9 17:05 upsd.users

The user "nut" has to be able to read this file or else instant 
commands (like battery test, timed shutdowns, etc.) don't work.

Version-Release number of selected component (if applicable):
nut-2.0.0-1

How reproducible:
Always

Steps to Reproduce:
1. upscmd ups@localhost test.battery.start
    

Actual Results:  Instant command failed: Access denied


Expected Results:  No output from upscmd, followed by a message that 
the ups is on battery.

Additional info:
Comment 1 Ngo Than 2004-05-10 17:00:02 EDT
it's fixed in 2.0.0-2. Many thanks for your report
Comment 2 Carlos Rodrigues 2004-07-09 14:38:21 EDT
2.0.0-2 isn't included in FC2. Maybe this is worth putting in updates?

Note You need to log in before you can comment on or make changes to this bug.