Bug 122868 - hotplug of usb-storage compactflash only works once
hotplug of usb-storage compactflash only works once
Status: CLOSED DUPLICATE of bug 119140
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 12:46 EDT by Ed Halley
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Halley 2004-05-09 12:46:40 EDT
Description of problem:

On first insert of a usb-storage compactflash card reader, the hotplug
scripts properly (mkdir /mnt/flash) and update the fstab.  On unmount
and removal, the hotplug scripts properly reverse this process.

On second and subsequent inserts, hotplug activity seems to run, but
no (mkdir /mnt/flash) and no fstab changes.  The dmesg doesn't seem to
be any different.

Version-Release number of selected component (if applicable):
  kernel 2.6.5-356

How reproducible:
  Every reboot.

Steps to Reproduce:
1.  Reboot system.
2.  Plug usb-storage device.  Note proper /mnt/flash.  Unmount.
3.  Plug usb-storage device again.  Note no /mnt/flash.

Additional Info:
Worked okay on 2.4 kernel series.  Not sure if it's a hotplug,
usb-storage, or kernel issue.
Comment 1 Bill Nottingham 2004-05-21 15:53:14 EDT
Odd. What happens if you manually run updfstab after the second insertion?
Comment 2 Ed Halley 2004-05-21 16:51:15 EDT
Now installed to final FC2 without any additional updates or software.

Running updfstab does the proper (mkdir /mnt/flash) and the device can
then be mounted.

Here is dmesg tail for the first iteration and the second iteration.

First iteration:  insert, mount, examine, umount, yank.
----
usb 4-2: new full speed USB device using address 2
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
  Vendor: eUSB      Model: Compact Flash     Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sda: 251904 512-byte hdwr sectors (129 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
 sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
USB Mass Storage device found at 2
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb 4-2: USB disconnect, address 2
----

Second iteration: insert.
----
usb 4-2: new full speed USB device using address 3
scsi1 : SCSI emulation for USB Mass Storage devices
  Vendor: eUSB      Model: Compact Flash     Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sda: 251904 512-byte hdwr sectors (129 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
 sda: sda1
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
USB Mass Storage device found at 3
----

Notice no "usbcore: registered new driver usb-storage" and no "USB
Mass Storage support registered."

After updfstab, the /mnt/flash was created and mountable.

After umount and yank, "usb 4-2: USB disconnect, address 3".
Comment 3 Lee Wittenberg 2004-09-10 19:07:57 EDT
Modifying the /etc/hotplug/usb.agent file (hotplug-2004_04_01-1) thus:

434a435,437
>     if [ -x /usr/sbin/updfstab ]; then
>         /usr/sbin/updfstab
>     fi

seems to fix the problem.  
Comment 4 Bill Nottingham 2005-02-04 16:05:54 EST

*** This bug has been marked as a duplicate of 119140 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:03:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.