Bug 122870 - Unknown User postfix and groud postdrop
Unknown User postfix and groud postdrop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 13:51 EDT by Matthias Runge
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 10:52:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2004-05-09 13:51:07 EDT
Description of problem: 
After installation of postfix, postfix complains about unknown user
postfix and unknown group postdrop. This problem could exist in prior
versions of fc2, too, but not in fc1.

Version-Release number of selected component (if applicable):


How reproducible: at installation (never changes)


Steps to Reproduce:
1. install fc2-test3 (incl. sendmail)
2. install postfix
3. switch from sendmail to postfix
  
Actual results:
postfix does not start.

Expected results:
The user postfix and the group postdrop should be
created by the installer (or the rpm script)

Additional info:
none
Comment 1 John Dennis 2004-05-10 13:35:57 EDT
The spec file does do this, see below snipet. I don't know how you ran
into this problem other than perhaps selinux security policy
preventing from successfully creating the new groups and user. Is
there anything in your logs saying the groupadd and useradd failed?

%pre
# Add user and groups if necessary
%{_sbindir}/groupadd -g %{maildrop_gid} -r %{maildrop_group} 2>/dev/null
%{_sbindir}/groupadd -g %{postfix_gid} -r %{postfix_group} 2>/dev/null
%{_sbindir}/groupadd -g 12 -r mail 2>/dev/null
%{_sbindir}/useradd -d %{postfix_queue_dir} -s /sbin/nologin -g
%{postfix_group} -G mail -M -r -u %{postfix_uid} %{postfix_user}
2>/dev/null
exit 0
Comment 2 Matthias Runge 2004-05-11 03:07:01 EDT
Since I was the only person getting this problem, I'd like to close
this bug. There is a groupadd and useradd in the install script, so
others shouldn't run in this mess. I had tons of complaints regarding
selinux securtity policies, but I am not sure to use the latest
policies at installing postfix.

Thanks for your time and effort.

Note You need to log in before you can comment on or make changes to this bug.