Bug 122875 - cardmgr not finding sockets
cardmgr not finding sockets
Status: CLOSED DUPLICATE of bug 121742
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 17:11 EDT by Jim Nuth
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Nuth 2004-05-09 17:11:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
On a thinkpad A31p when starting most of the time the boot.log shows

May  9 20:59:12 laptop pcmcia: Starting PCMCIA services: 
May  9 20:59:12 laptop pcmcia: cardmgr[1953]: no sockets found!
May  9 20:59:12 laptop pcmcia: done.

Worked fine under core 1. 

Occasionally cardmgr will report it's watching 2 sockets.

using an orinoco wireless card and an IBM bluetooth card

Version-Release number of selected component (if applicable):
core2-test3 yum update as of 9th May 7pm GMT

How reproducible:
Sometimes

Steps to Reproduce:
1. start laptop
2. insert pcmcia card
3. look a boot log
    

Actual Results:  card did nothing, no beeps, no lights etc

Expected Results:  beeps and lights

Additional info:
Comment 1 Mark Howell 2004-05-09 19:35:19 EDT
Same behavior on my Dell Inspiron 7500 PIII-700, 512MB RAM, Sony
PCWA-C150S 802.11b card and Xircom CBE2-100 10/100 Ethernet.

This is with a fresh install of FC2T3 from DVD.
Comment 2 Antti Markus 2004-05-10 05:13:06 EDT
What happens if you execute /sbin/modprobe yenta_socket before
inserting PCMCIA card?
Comment 3 Timothy Sandel 2004-05-10 15:12:14 EDT
I have the same problem with Cisco 350.  If I modprobe yenta_socket
and restart pcmcia service I can get the card to work.  I have a
Winbook X4 with a P4 1.8 and 256mb ram.
Comment 4 Jim Nuth 2004-05-10 16:02:23 EDT
From # 
/sbin/modprobe yenta_socket  then
service pcmcia restart

reports cardmgr: watching 2 sockets
inserting either card and I get lights and functioning cards.

Thanks

Jim
Comment 5 D. Brian Gosnell 2004-05-18 05:04:02 EDT
Had the problem with an orinoco card in a Dell 4150.

/sbin/rmmod orinoco_cs
/sbin/rmmod ds
/etc/init.d/pcmica restart

and cardmgr seems to work..
Comment 6 David Turvene 2004-05-27 11:40:40 EDT
Setup: Linksys card in a Toshiba Tecra 8100.

The "modprobe yenta_socket; service pcmcia restart" steps work for me

To make this permanent, I followed the instructions to reorder 
S10network in

http://www.fedoraforum.org/forum/showthread.php?
s=06639a918d6493c8944aaadc621812a3&threadid=1762
Comment 7 David Tonhofer 2004-06-17 16:02:04 EDT
I have that problem with Fedora 2 on a Dell Laptop, with or 
without a single ELSA ISDN card. Actually, the ELSA used to
work!! (But see bug 125135 for erratic behaviour of that card
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125135)

Yesterday Fedora decided to no longer find any sockets. 
Mystifying. Things work well under Windows. Tried to load/unload
the kernel modules (elsa, ds, pcmcia) to no avail. cardmgr -v does
not give any additional information. 

Will try the yenta_socket (what the heck is THAT?) thing and report
now..
Comment 8 David Tonhofer 2004-06-17 16:32:24 EDT
Yup, works. The question is: what makes Linux load (or not?)
yenta_socket? And would it change?
Comment 9 Bill Nottingham 2004-09-08 02:57:37 EDT

*** This bug has been marked as a duplicate of 121742 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:03:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.