Bug 122877 - (IT#36528) /usr/lib64/libmyodbc.so: undefined symbol: _dig_vec
/usr/lib64/libmyodbc.so: undefined symbol: _dig_vec
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: MyODBC (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
:
: 134839 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-09 18:08 EDT by Ben Levenson
Modified: 2013-07-02 23:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 19:37:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2004-05-09 18:08:41 EDT
Description of problem:
I noticed this problem while testing unixODBC on s390x and x86_64:
# /usr/bin/dltest /usr/lib64/libmyodbc.so
[dltest] ERROR: /usr/lib64/libmyodbc.so: undefined symbol: _dig_vec

Version-Release number of selected component (if applicable):
2.50.39-12
platforms: s390x and x86_64

works as expected on x86, ia64, ppc
Comment 1 Alexandre Oliva 2004-10-06 18:00:29 EDT
*** Bug 134839 has been marked as a duplicate of this bug. ***
Comment 3 Tom Lane 2004-11-11 15:45:24 EST
Turns out that libmyodbc.so was being built without any dependency on
libraries in /usr/lib64, due to using an obsolete version of libtool.

Fixed in MyODBC-2.50.39-12.1.
Comment 6 Tim Powers 2005-05-19 19:37:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-441.html

Note You need to log in before you can comment on or make changes to this bug.