Bug 1228985 - Cinnamon does not find Applet configurations on login
Summary: Cinnamon does not find Applet configurations on login
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1229039 1229094 1229137 1229410 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-07 10:10 UTC by Steve Bryant
Modified: 2015-06-09 16:27 UTC (History)
11 users (show)

Fixed In Version: cinnamon-translations-2.6.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-09 15:03:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Steve Bryant 2015-06-07 10:10:39 UTC
Description of problem:
Since upgrade to Cinnamon 2.6.6, on login to Cinnamon desktop, the main Menu applet is empty except for the search field and the Panel Launcher is missing is missing.

Version-Release number of selected component (if applicable):
cinnamon-2.6.6-1.fc22.x86_64

How reproducible:
Log into Cinnamon desktop - 

Steps to Reproduce:
1. Log out of Cinnamon, or reboot
2. Log in to Cinnamon
3.

Actual results:
Empty Menu, missing Panel Launcher.

Expected results:
Previous session's configuration of Menu and and Launcher should be present at login.

Additional info:
To recover Menu configuration, you need to configure the Menu applet and access the Menu Editor.  Making a trivial change (e.g. unchecking then rechecking a menu item) and then closing forces the Menu applet to load all items.

To recover Panel Launcher, right-click an application on Menu and select "Add to Panel.  Panel Launcher then appears with previous applications plus the new application just added.

Comment 1 Fedora Update System 2015-06-07 10:38:17 UTC
cinnamon-translations-2.6.2-1.fc21, cinnamon-screensaver-2.6.3-2.fc21, cinnamon-control-center-2.6.0-3.fc21, nemo-extensions-2.6.x-1.fc21, cinnamon-2.6.7-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-9608/nemo-extensions-2.6.x-1.fc21,cinnamon-translations-2.6.2-1.fc21,cinnamon-screensaver-2.6.3-2.fc21,cinnamon-control-center-2.6.0-3.fc21,cinnamon-2.6.7-2.fc21

Comment 2 Fedora Update System 2015-06-07 10:38:34 UTC
cinnamon-translations-2.6.2-1.fc20, cinnamon-screensaver-2.6.3-2.fc20, nemo-extensions-2.6.x-1.fc20, cinnamon-control-center-2.6.0-3.fc20, cinnamon-2.6.7-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2015-9615/nemo-extensions-2.6.x-1.fc20,cinnamon-translations-2.6.2-1.fc20,cinnamon-screensaver-2.6.3-2.fc20,cinnamon-control-center-2.6.0-3.fc20,cinnamon-2.6.7-2.fc20

Comment 3 Fedora Update System 2015-06-07 10:39:05 UTC
cinnamon-2.6.7-2.fc22, nemo-extensions-2.6.x-1.fc22, cinnamon-translations-2.6.2-1.fc22, cinnamon-control-center-2.6.0-3.fc22, cinnamon-screensaver-2.6.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-9595/nemo-extensions-2.6.x-1.fc22,cinnamon-translations-2.6.2-1.fc22,cinnamon-screensaver-2.6.3-2.fc22,cinnamon-control-center-2.6.0-3.fc22,cinnamon-2.6.7-2.fc22

Comment 4 Tom Georgoulias 2015-06-07 12:43:38 UTC
Is there a quick way to get a hold of these fixed RPMs?

Comment 5 stasi 2015-06-07 12:54:33 UTC
Yes, please leave karma if you have a fas account.

Comment 6 leigh scott 2015-06-07 12:55:34 UTC
(In reply to Tom Georgoulias from comment #4)
> Is there a quick way to get a hold of these fixed RPMs?

Follow the links on the update tickets.

Or search koji


https://koji.fedoraproject.org/koji/builds

Comment 7 Fedora Update System 2015-06-07 16:02:24 UTC
Package cinnamon-2.6.7-2.fc22, nemo-extensions-2.6.x-1.fc22, cinnamon-translations-2.6.2-1.fc22, cinnamon-control-center-2.6.0-3.fc22, cinnamon-screensaver-2.6.3-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-2.6.7-2.fc22 nemo-extensions-2.6.x-1.fc22 cinnamon-translations-2.6.2-1.fc22 cinnamon-control-center-2.6.0-3.fc22 cinnamon-screensaver-2.6.3-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9595/nemo-extensions-2.6.x-1.fc22,cinnamon-translations-2.6.2-1.fc22,cinnamon-screensaver-2.6.3-2.fc22,cinnamon-control-center-2.6.0-3.fc22,cinnamon-2.6.7-2.fc22
then log in and leave karma (feedback).

Comment 8 Tom Georgoulias 2015-06-07 17:47:57 UTC
Thanks, I had to install cinnamon with --nodeps to get around a blueman dep (it wasn't installed on my laptop anyway) but that was the only issue.

Menu and panel behavior are back to normal for me.

Comment 9 Steve Bryant 2015-06-07 20:02:13 UTC
Thanks - running the following command as 'root' also fixed the issue for me:

# dnf --enablerepo=updates-testing upgrade cinnamon\* nemo\*

(It did have to try a number of mirrors to find a copy of 'blueman' with a valid checksum - perhaps repo sync was not complete?)

Comment 10 leigh scott 2015-06-07 20:02:37 UTC
*** Bug 1229039 has been marked as a duplicate of this bug. ***

Comment 11 leigh scott 2015-06-08 06:03:23 UTC
*** Bug 1229094 has been marked as a duplicate of this bug. ***

Comment 12 leigh scott 2015-06-08 11:53:19 UTC
*** Bug 1229137 has been marked as a duplicate of this bug. ***

Comment 13 leigh scott 2015-06-08 17:40:47 UTC
*** Bug 1229410 has been marked as a duplicate of this bug. ***

Comment 14 Steevithak 2015-06-08 17:52:32 UTC
Same problem here. Did a "yum update" today and now cinnamon is unusable.

Comment 15 Steevithak 2015-06-08 17:55:35 UTC
Can the fix above be used on Fedora 21 or is a similar fix in the works?

Comment 16 Neil 2015-06-08 18:23:31 UTC
It's not I recommend you to upgrade to f22 using fedup, so you can be able to test most fixes on testing repositories, since our selected DE is half of the experience using fedora, I can confirm that f22 is stable as f21, almost with the same issues on cinnamon the difference is that you can test the latest fixes.

Comment 17 Fedora Update System 2015-06-09 15:03:41 UTC
cinnamon-translations-2.6.2-1.fc21, cinnamon-screensaver-2.6.3-2.fc21, cinnamon-control-center-2.6.0-3.fc21, nemo-extensions-2.6.x-1.fc21, cinnamon-2.6.7-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-06-09 15:05:05 UTC
cinnamon-2.6.7-2.fc22, nemo-extensions-2.6.x-1.fc22, cinnamon-translations-2.6.2-1.fc22, cinnamon-control-center-2.6.0-3.fc22, cinnamon-screensaver-2.6.3-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2015-06-09 15:17:26 UTC
cinnamon-translations-2.6.2-1.fc20, cinnamon-screensaver-2.6.3-2.fc20, nemo-extensions-2.6.x-1.fc20, cinnamon-control-center-2.6.0-3.fc20, cinnamon-2.6.7-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Steevithak 2015-06-09 16:27:56 UTC
Turns out updating cinnamon from the test repo actually did fix both my Fedora 21 and Fedora 20 boxes that had this problem. (yes, upgrading to F22 is planned but I need to keep the desktop working until I have time to do the upgrades). Thanks!


Note You need to log in before you can comment on or make changes to this bug.