Bug 122910 - pre-definition of mailbox_transport lmtp socket path
pre-definition of mailbox_transport lmtp socket path
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
: FutureFeature
: 145277 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-10 08:13 EDT by Alexander Dalloz
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 09:22:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Dalloz 2004-05-10 08:13:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.4.1)
Gecko/20031114

Description of problem:
For users wanting to run Postfix in conjunction with Cyrus-IMAPd it
would be good to have a pre-configured, evem commented line in the
/etc/postfix/main.cf for the mailbox_transport to point to the correct
path for the lmtp socket:

mailbox_transport = lmtp:unix:/var/imap/socket/lmtp

Version-Release number of selected component (if applicable):
postfix-2.0.18-4

How reproducible:
Always

Steps to Reproduce:
1. installation of Postfix
2. /etc/postfix.main.cf just contains: #mailbox_transport = cyrus    

Additional info:

See
http://asg.web.cmu.edu/cyrus/download/imapd/install-configure.html#mta
-> Configuring Postfix
Comment 1 Alexander Dalloz 2004-05-10 10:07:31 EDT
Besides the main.cf entry it should be checked whether the
/etc/postfix/master.cf definition of the cyrus transport is proper:

cyrus     unix  -       n       n       -       -       pipe
  user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension}
${user}

To where is that path pointing, a chroot? Sorry, as being a Sendmail
user I lack some important knowledge about Postfix.
Comment 2 Chris Ricker 2004-05-13 16:26:34 EDT
The only change I remember being necessary for master.cf is to correct
the path "/cyrus/bin/deliver" to "/usr/lib/cyrus-imapd/deliver" -- the
"/cyrus/bin" stuff is just Wietse's notation for "wherever the cyrus
binaries happen to be on your system"

The old-cyrus transport line should perhaps be commented out to avoid
confusion as well...

/usr/share/doc/postfix-mumble/README_FILES/LMTP_README already covers
all the ways of connecting Postfix and Cyrus using LMTP....
Comment 3 Mads Kiilerich 2004-09-28 19:16:54 EDT
fc3test2's postfix-2.1.4-1.src.rpm's master.cf still refers to
/cyrus/bin/deliver, even though the cyrus-imapd package puts it in
/usr/lib/cyrus-imapd/deliver

Wietse can't know it in general, but we know where it is placed, and
the packages should be configured to work with each other out-of-the-box. 

Comment 4 Chris Ricker 2005-01-28 11:22:17 EST
*** Bug 145277 has been marked as a duplicate of this bug. ***
Comment 5 John Dennis 2005-01-28 14:14:29 EST
With respect to comment #1, the correct parameter is:

mailbox_transport = lmtp:unix:/var/lib/imap/socket/lmtp

Note, files are installed in /var/lib/imap now instead of /var/imap.

With respect to comments #2 and #3,
/usr/lib/cyrus-imapd/deliver
is the correct path for our installation.

With respect to postfix/cyrus-imapd configuration. Although the
"deliver" mechanism should still work my understanding is that it is
deprecated in favor of lmtp since both postfix and cyrus now support
it. Whenever I test the postfix/cyrus compbination I use lmtp, not
"deliver". Perhaps we should remove references to "cyrus" in main.cf
and "deliver" in master.cf as an encouragement to use the lmtp
mechanism and to simplify things.

Here is my suggest

# If using the cyrus-imapd IMAP server deliver local mail to the IMAP
# sever using LMTP (Local Mail Transport Protocol), this is prefered
# over the older cyrus deliver program by setting the
# mailbox_transport as below:
#
# mailbox_transport = lmtp:unix:/var/lib/imap/socket/lmtp
#
# The efficiency of LMTP delivery for cyrus-imapd can be enhanced via
# these settings.
#
# local_destination_recipient_limit = 300
# local_destination_concurrency_limit = 5
#
# Of course you should adjust these settings as appropriate for the
# capacity of the hardware you are using. The recipient limit setting
# can be used to take advantage of the single instance message store
# capability of Cyrus. The concurrency limit can be used to control
# how many simultaneous LMTP sessions will be permitted to the Cyrus
# message store. 


This bug was just assigned to me as the owner of cyrus-imapd, but the
changes belong in the postfix rpm. If there is agreement that my
suggestions are appropriate then I think the postfix maintainer
(Thomas?) should do the rpm editing so we don't step on each others
toes in the various CVS branches.

BTW, the postfix LMTP readment file seems to have disappeared, its not
in the distribution any more (technically it there, but the contents
say the info in on the web site), but on the postfix doc page cyrus
was empty, LMTP, was empty, and it was not discussed in the general
configuration pages (maybe I missed it?).
Comment 6 Alexander Dalloz 2005-01-30 13:29:39 EST
John,
your suggestion about the comment on how using the LMTP mail transport
between Postfix and Cyrus-IMAPd sounds reasonable to me as it is then
simple to adjust the setup.
And yes, the Postfix maintainer - is it Thomas Wörner? - should be
notified. (The RFE bugzilla entry was made for the Postfix package by me.)
Comment 7 Thomas Woerner 2005-11-11 09:22:09 EST
Fixed in rawhide in package postfix-2.2.5-2.1 or newer.

Note You need to log in before you can comment on or make changes to this bug.