Bug 1229105 - (6.4.z) DataContainer should interact atomically with Persistence
Summary: (6.4.z) DataContainer should interact atomically with Persistence
Keywords:
Status: CLOSED DUPLICATE of bug 1202354
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering
Version: 6.4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: baranowb
QA Contact: Jitka Kozana
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-08 05:25 UTC by baranowb
Modified: 2015-06-11 15:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-11 15:33:27 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3797 Major Resolved DataContainer should interact atomically with Persistence 2019-08-20 13:51:08 UTC

Description baranowb 2015-06-08 05:25:49 UTC
DataContainer should handle atomically all the interactions with the Persistence. This includes all the eviction/passivation.
Main points:
In DataContainer load/store will avoid any lose of data during concurrent operations
Take advantage of CHMv8
CacheLoader and Writer Interceptors are no longer needed.
Check the mailling list for more info.

Comment 4 dereed 2015-06-11 15:33:27 UTC
Closing as duplicate of BZ1202354

*** This bug has been marked as a duplicate of bug 1202354 ***


Note You need to log in before you can comment on or make changes to this bug.