Bug 1229160 - implausibly old time stamp 1970-01-01 00:00:00 on Atomic files
Summary: implausibly old time stamp 1970-01-01 00:00:00 on Atomic files
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
: 1186411 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-08 08:23 UTC by Jan Pazdziora
Modified: 2017-07-07 12:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-07 12:56:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 750565 None None None 2019-02-01 21:35:49 UTC

Description Jan Pazdziora 2015-06-08 08:23:52 UTC
Description of problem:

When I install Atomic Host, some files have mtime set to 1970-01-01 UTC, for example /etc/ssh/ssh_config or /etc/pam.d/sshd.

Full list can be found using

find / ! -mnewer /etc/ssh/ssh_config

Version-Release number of selected component (if applicable):

# cat /etc/redhat-release 
Red Hat Enterprise Linux Atomic Host release 7.1
# rpm-ostree status
  TIMESTAMP (UTC)         VERSION     ID             OSNAME          REFSPEC                                            
* 2015-06-06 12:53:05     7.1.574     d1c0d69c20     atomic-host     atomic-host:rhel-atomic-host/7/x86_64/standard     

How reproducible:

Deterministic.

Steps to Reproduce:
1. Run # export TZ=UTC ; tar cf - /etc/ssh/ssh_config /etc/pam.d/sshd | ( cd /tmp && tar xvf - )

Actual results:

tar: Removing leading `/' from member names
etc/ssh/ssh_config
tar: etc/ssh/ssh_config: implausibly old time stamp 1970-01-01 00:00:00
etc/pam.d/sshd
tar: etc/pam.d/sshd: implausibly old time stamp 1970-01-01 00:00:00

Expected results:

No warnings, mtime not set to epoch.

Additional info:

Comment 2 Colin Walters 2015-06-08 13:20:43 UTC
That's expected, OSTree intentionally does not carry file timestamps.

https://mail.gnome.org/archives/ostree-list/2015-February/msg00008.html
https://git.gnome.org/browse/ostree/commit/?id=fe5ed36461a52b38cb366162bfd222ad3b326bf2

It's unfortunate that tar complains, but we'll just have to live with it.

Although we *could* set file timestamps to be newer for the copies of files in /etc...I'll file a bug to look at that.

Comment 3 Colin Walters 2016-06-22 13:49:43 UTC
*** Bug 1186411 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2016-10-18 16:55:45 UTC
Should this bug be closed?

Comment 5 Colin Walters 2017-07-06 21:21:51 UTC
This was incidentally fixed a while ago for files, and tar no longer warns.  But directories still have 0 timestamps.

Comment 6 Colin Walters 2017-07-06 21:24:39 UTC
Filed that here https://github.com/ostreedev/ostree/issues/995

Comment 7 Colin Walters 2017-07-07 12:56:54 UTC
There's a PR for this upstream; I don't think it's worth tracking this here too.  The fix will make its way downstream soon enough.


Note You need to log in before you can comment on or make changes to this bug.