Bug 1229172 - [AFR-V2] - Fix shd coredump from tests/bugs/glusterd/bug-948686.t
Summary: [AFR-V2] - Fix shd coredump from tests/bugs/glusterd/bug-948686.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1229550 1233036 1233144
TreeView+ depends on / blocked
 
Reported: 2015-06-08 08:41 UTC by Krutika Dhananjay
Modified: 2016-06-16 13:09 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1229550 1233036 1233144 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:09:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-06-08 08:41:57 UTC
Description of problem:
http://www.gluster.org/pipermail/gluster-devel/2015-June/045499.html


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Krutika Dhananjay 2015-06-08 08:47:32 UTC
http://review.gluster.org/#/c/11119/

Comment 2 Anand Avati 2015-06-09 03:24:33 UTC
COMMIT: http://review.gluster.org/11119 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 7ca78f7a6466a0f2ff19caff526f6560b5275f69
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Jun 8 11:36:12 2015 +0530

    cluster/afr: Do not attempt entry self-heal if the last lookup on entry failed on src
    
    Test bug-948686.t was causing shd to dump core due to gfid being NULL.
    This was due to the volume being stopped while index heal's in progress,
    causing afr_selfheal_unlocked_lookup_on() to fail sometimes on the src brick
    with ENOTCONN. And when afr_selfheal_newentry_mark() copies the gfid off the
    src iatt, it essentially copies null gfid. This was causing the assertion
    as part of xattrop in protocol/client to fail.
    
    Change-Id: I237a0d6b1849e4c48d7645a2cc16d9bc1441ef95
    BUG: 1229172
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/11119
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 14:56:54 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:09:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.