Bug 1229177 - Vdsm for EL7 should not allow engine version lower than 3.5
Summary: Vdsm for EL7 should not allow engine version lower than 3.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Yaniv Bronhaim
QA Contact: Petr Kubica
URL:
Whiteboard:
Depends On: 1254147
Blocks: 1234320
TreeView+ depends on / blocked
 
Reported: 2015-06-08 08:49 UTC by Roman Hodain
Modified: 2016-03-09 19:41 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
This change disables the ability to use VDSM in clusters from 3.0 to 3.3. Red Hat Enterprise Virtualization 3.6 drops support for cluster levels between 3.0 and 3.3 and Manager versions 3.3 and below. Support for Red Hat Enterprise Virtualization Manager 3.4 is still available as tech-preview.
Clone Of:
: 1234320 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:41:03 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 42247 ovirt-3.5 MERGED Modifying vdsm supported cluster end engine versions for el6 and el7 2020-09-30 15:52:53 UTC
oVirt gerrit 42303 master MERGED Vdsm version 4.16 and above does not support cluster level 3.3 and below 2020-09-30 15:52:53 UTC

Description Roman Hodain 2015-06-08 08:49:56 UTC
Description of problem:
vdsm for EL7 currently support all engine versions since 3.0. This is not correct as vdsm for EL7 is only supporte on engine 3.5 and higher.

Version-Release number of selected component (if applicable):
vdsm-4.16.8.1-4.el7ev

How reproducible:
100%

Steps to Reproduce:
Register EL7 as hypervisor in engine < 3.5

Actual results:
hypervisor is activated

Expected results:
Errar message should be reported.

Comment 1 Barak 2015-06-09 12:51:24 UTC
Should we also remove 3.2, 3.1 & 3.0 from the clusterLevels supported ?

Comment 5 Scott Herold 2015-06-11 13:37:17 UTC
(In reply to Barak from comment #1)
> Should we also remove 3.2, 3.1 & 3.0 from the clusterLevels supported ?

Yes.  Remove these.  EL 7 Hosts are only officially supported on cluster level 3.5 and in Tech Preview on 3.4.

Comment 6 Oved Ourfali 2015-06-11 14:37:35 UTC
Based on discussion offline, and comments in the bug, we will do the following in VDSM in EL7:
1. Remove clusterLevels 3.0-3.3
2. set supportedEngines to 3.4 (due to tech-preview) and above.

Comment 8 Max Kovgan 2015-06-28 14:12:27 UTC
ovirt-3.6.0-3 release

Comment 9 Petr Kubica 2015-07-29 14:41:17 UTC
Hi, I tested adding 3.6.0-4 host to engine 3.4.4-1 and it's not working: "installation failed. Network error during communication with the host."
Should it works ?

but when I try add the host to 3.5.3.1-1 engine with cluster compatibility level 3.4 it works.  

I found only this error:
/var/log/messages
journal: vdsm ProtocolDetector.SSLHandshakeDispatcher ERROR Error during handshake: unexpected eof

/var/log/vdsm/vdsm.log:
Reactor thread::ERROR::2015-07-29 16:38:10,361::sslutils::336::ProtocolDetector.SSLHandshakeDispatcher::(handle_read) Error during handshake: unexpected eof
Reactor thread::INFO::2015-07-29 16:38:13,390::protocoldetector::72::ProtocolDetector.AcceptorImpl::(handle_accept) Accepting connection from 10.34.60.19:45925

Comment 10 Yaniv Bronhaim 2015-08-10 17:09:47 UTC
I suggest to open a separate bug on that issue which describes the vdsm and engine versions, os type, the flow you tried to run and contain related log

Comment 11 Petr Kubica 2015-08-31 08:05:11 UTC
Verified in vdsm-4.17.0-1239.git6575e3f.el7.noarch

Comment 13 errata-xmlrpc 2016-03-09 19:41:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.