Bug 1229177
| Summary: | Vdsm for EL7 should not allow engine version lower than 3.5 | |||
|---|---|---|---|---|
| Product: | Red Hat Enterprise Virtualization Manager | Reporter: | Roman Hodain <rhodain> | |
| Component: | vdsm | Assignee: | Yaniv Bronhaim <ybronhei> | |
| Status: | CLOSED ERRATA | QA Contact: | Petr Kubica <pkubica> | |
| Severity: | medium | Docs Contact: | ||
| Priority: | medium | |||
| Version: | 3.5.0 | CC: | bazulay, danken, fdeutsch, gklein, lpeer, lsurette, oourfali, pstehlik, sherold, s.kieske, ybronhei, yeylon, ykaul | |
| Target Milestone: | ovirt-3.6.0-rc | Keywords: | ZStream | |
| Target Release: | 3.6.0 | |||
| Hardware: | x86_64 | |||
| OS: | Linux | |||
| Whiteboard: | ||||
| Fixed In Version: | Doc Type: | Release Note | ||
| Doc Text: |
This change disables the ability to use VDSM in clusters from 3.0 to 3.3. Red Hat Enterprise Virtualization 3.6 drops support for cluster levels between 3.0 and 3.3 and Manager versions 3.3 and below. Support for Red Hat Enterprise Virtualization Manager 3.4 is still available as tech-preview.
|
Story Points: | --- | |
| Clone Of: | ||||
| : | 1234320 (view as bug list) | Environment: | ||
| Last Closed: | 2016-03-09 19:41:03 UTC | Type: | Bug | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | Infra | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | 1254147 | |||
| Bug Blocks: | 1234320 | |||
|
Description
Roman Hodain
2015-06-08 08:49:56 UTC
Should we also remove 3.2, 3.1 & 3.0 from the clusterLevels supported ? (In reply to Barak from comment #1) > Should we also remove 3.2, 3.1 & 3.0 from the clusterLevels supported ? Yes. Remove these. EL 7 Hosts are only officially supported on cluster level 3.5 and in Tech Preview on 3.4. Based on discussion offline, and comments in the bug, we will do the following in VDSM in EL7: 1. Remove clusterLevels 3.0-3.3 2. set supportedEngines to 3.4 (due to tech-preview) and above. ovirt-3.6.0-3 release Hi, I tested adding 3.6.0-4 host to engine 3.4.4-1 and it's not working: "installation failed. Network error during communication with the host." Should it works ? but when I try add the host to 3.5.3.1-1 engine with cluster compatibility level 3.4 it works. I found only this error: /var/log/messages journal: vdsm ProtocolDetector.SSLHandshakeDispatcher ERROR Error during handshake: unexpected eof /var/log/vdsm/vdsm.log: Reactor thread::ERROR::2015-07-29 16:38:10,361::sslutils::336::ProtocolDetector.SSLHandshakeDispatcher::(handle_read) Error during handshake: unexpected eof Reactor thread::INFO::2015-07-29 16:38:13,390::protocoldetector::72::ProtocolDetector.AcceptorImpl::(handle_accept) Accepting connection from 10.34.60.19:45925 I suggest to open a separate bug on that issue which describes the vdsm and engine versions, os type, the flow you tried to run and contain related log Verified in vdsm-4.17.0-1239.git6575e3f.el7.noarch Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://rhn.redhat.com/errata/RHBA-2016-0362.html |