Bug 1229230 - evolution-3.16.2.1-2 - hang editing message rules
Summary: evolution-3.16.2.1-2 - hang editing message rules
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-08 10:11 UTC by Davide Repetto
Modified: 2015-06-11 18:36 UTC (History)
4 users (show)

Fixed In Version: evolution-mapi-3.16.3-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-08 12:15:27 UTC


Attachments (Terms of Use)
File gotten after the fact from: .config/evolution/mail (13.82 KB, application/zip)
2015-06-08 10:21 UTC, Davide Repetto
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 750560 None None None Never

Description Davide Repetto 2015-06-08 10:11:51 UTC
Description of problem:
=======================
Evolution slow down or hang after some editing of message rules.
The resulting message rules file has a lot of duplicate lines.

Version-Release:
===============
evolution-3.16.2.1-2.fc22.x86_64

How reproducible:
=================
I'm not really sure. With my rules just doing a few mods here and there seems to make it happen.

Comment 1 Davide Repetto 2015-06-08 10:21:42 UTC
Created attachment 1036280 [details]
File gotten after the fact from: .config/evolution/mail

Comment 2 Milan Crha 2015-06-08 12:15:27 UTC
Thanks for a bug report. I can reproduce it too, for example when using filter rules like: [Subject] [Contains] [text]. This is not a Fedora specific issue, thus I move this upstream for better visibility. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=750560

Comment 3 Fedora Update System 2015-06-08 16:18:07 UTC
evolution-mapi-3.16.3-1.fc22, openchange-2.2-7.fc22, evolution-ews-3.16.3-1.fc22, evolution-data-server-3.16.3-1.fc22, evolution-3.16.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/evolution-mapi-3.16.3-1.fc22,openchange-2.2-7.fc22,evolution-ews-3.16.3-1.fc22,evolution-3.16.3-2.fc22,evolution-data-server-3.16.3-1.fc22

Comment 4 Davide Repetto 2015-06-08 16:56:55 UTC
Wow! Incredibly fast is becoming your "as usual"... :)
Thanks Milan!

Since in [1] you suggest that people should clean the configs by hand, for those who want an easy clean-up I suggest to use uniq as in:

uniq '~/.config/evolution/mail/filters.xml' > uniq.tmpfile
mv uniq.tmpfile '~/.config/evolution/mail/filters.xml'


[1] https://bugzilla.gnome.org/show_bug.cgi?id=750560

Comment 5 Davide Repetto 2015-06-08 16:59:29 UTC
Uh! Sorry. Wrong quotes. The lines shoud be without quotes:

uniq ~/.config/evolution/mail/filters.xml > uniq.tmpfile
mv uniq.tmpfile ~/.config/evolution/mail/filters.xml

Comment 6 Fedora Update System 2015-06-11 18:36:05 UTC
evolution-mapi-3.16.3-1.fc22, openchange-2.2-7.fc22, evolution-ews-3.16.3-1.fc22, evolution-data-server-3.16.3-1.fc22, evolution-3.16.3-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.