Bug 122928 - kudzu breaks 3c59x PCI cards
Summary: kudzu breaks 3c59x PCI cards
Status: CLOSED DUPLICATE of bug 107389
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-10 15:23 UTC by Walter R. Moore
Modified: 2014-03-17 02:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Walter R. Moore 2004-05-10 15:23:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
3c59x works fine until kudzu runs. 

# grep eth0 /etc/modprobe.conf
alias eth0 3c59x

# lspci | grep Ethernet
00:13.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]

After kudzu runs ifup|ifdown act normal but there is no network
activity and these errors show on console:
eth0: Resetting the Tx ring pointer.
eth0: Transmit error, Tx status register 90.
  Flags; bus-master 1, dirty 1(1) current 17(1)
  Transmit list 06f75340 vs. 08f752a0.
  0: @08f75200  length 8000002a status 8000002a
  1: @08f752a0  length 80000046 status 00000046
  2: @08f75340  length 80000046 status 00000046
  3: @08f753e0  length 8000002a status 0000002a
  4: @08f75480  length 8000002a status 0000002a
  5: @08f75520  length 8000002a status 0000002a
  6: @08f755c0  length 8000002a status 0000002a
  7: @08f75660  length 8000002a status 0000002a
  8: @08f75700  length 8000002a status 0000002a
  9: @08f757a0  length 8000002a status 0000002a
  10: @08f75840  length 8000002a status 0000002a
  11: @08f758e0  length 8000002a status 0000002a
  12: @08f75980  length 8000002a status 0000002a
  13: @08f75a20  length 8000002a status 0000002a
  14: @08f75ac0  length 8000002a status 0000002a
  15: @08f75b60  length 8000002a status 8000002a

Resetting the system brings the card back to life. The only workaround
I've seen is turning kudzu off with chkconfig.

Version-Release number of selected component (if applicable):
kudzu-1.1.62-1

How reproducible:
Always

Steps to Reproduce:
1.run kudzu from rc or command line
2.
3.
    

Actual Results:  After kudzu runs ifup|ifdown act normal but there is
no network activity and these errors show on console:
eth0: Resetting the Tx ring pointer.
eth0: Transmit error, Tx status register 90.
  Flags; bus-master 1, dirty 1(1) current 17(1)
  Transmit list 06f75340 vs. 08f752a0.
  0: @08f75200  length 8000002a status 8000002a
  1: @08f752a0  length 80000046 status 00000046
  2: @08f75340  length 80000046 status 00000046
  3: @08f753e0  length 8000002a status 0000002a
  4: @08f75480  length 8000002a status 0000002a
  5: @08f75520  length 8000002a status 0000002a
  6: @08f755c0  length 8000002a status 0000002a
  7: @08f75660  length 8000002a status 0000002a
  8: @08f75700  length 8000002a status 0000002a
  9: @08f757a0  length 8000002a status 0000002a
  10: @08f75840  length 8000002a status 0000002a
  11: @08f758e0  length 8000002a status 0000002a
  12: @08f75980  length 8000002a status 0000002a
  13: @08f75a20  length 8000002a status 0000002a
  14: @08f75ac0  length 8000002a status 0000002a
  15: @08f75b60  length 8000002a status 8000002a


Expected Results:  Networking should continue to work.

Additional info:

Comment 1 Bill Nottingham 2004-05-21 20:19:13 UTC

*** This bug has been marked as a duplicate of 107389 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:03:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.