Bug 1229384 - Cannot create partition table with one symbol in name
Summary: Cannot create partition table with one symbol in name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.1.0
Hardware: All
OS: All
high
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-08 15:00 UTC by Oleksandr Shtaier
Modified: 2019-09-25 21:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:52:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
WebUI Error (23.29 KB, image/png)
2015-06-08 15:00 UTC, Oleksandr Shtaier
no flags Details
[Verified] Screenshot Attached (133.11 KB, image/png)
2016-04-01 08:59 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Oleksandr Shtaier 2015-06-08 15:00:56 UTC
Created attachment 1036408 [details]
WebUI Error

Description of problem:
When I try to create partition table with one letter in name, I get:

WebUI:
"can't contain trailing white spaces" error

API:
422 Client Error: Unprocessable Entity:
"error": {"full_messages":["Name can't contain trailing white spaces."]}

CLI:
Could not create the partition table:
    Name can't contain trailing white spaces.

Version-Release number of selected component (if applicable):
Sat 6.1 GA snap 7

How reproducible:
Always


Steps to Reproduce:
1. Try to create new partition table using one symbol (for example "T") as its name

Actual results:
Partition table is not created and error message is thrown


Expected results:
Partition table created successfully


Additional info:

Comment 2 Bryan Kearney 2015-12-18 16:15:10 UTC
This is fixed upstream, verified this on 1.11 devel.

Comment 3 sthirugn@redhat.com 2016-01-29 15:42:03 UTC
Moving to POST as the fix is still in upstream only.

Comment 6 Jitendra Yejare 2016-04-01 08:59:49 UTC
Created attachment 1142480 [details]
[Verified] Screenshot Attached

Comment 7 Jitendra Yejare 2016-04-01 09:00:07 UTC
Verified this issue in Sat 6.2 snap 6.0

The bug is no more reproducible.

I see the partition table is created with symbol/letter as mentioned in description of bug. [Screenshot Attached]

So moving the bug as Verified.

Comment 9 errata-xmlrpc 2016-07-27 08:52:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.