Bug 122940 - USB fails to load with kernel2.6.5-1.327
USB fails to load with kernel2.6.5-1.327
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-10 12:35 EDT by John F Meinel Jr
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 15:45:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John F Meinel Jr 2004-05-10 12:35:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
My machine has a Intel 8280 1DB/DBM USB controller built into the
motherboard. After installing Fedora Core 2 test3 (stock) when it
reboots it tries to initialize USB and fails. This prevents my
keyboard and mouse from working. I am able to ssh into the machine to
try things, and I'm willing to try and work through it.

The USB support works fine during the install, so I'm guessing this is
a USB 2.0 bug. I assume the installer only knows about USB 1.0. Is
there a way to disable uhci_hcd from trying to do USB 2?

What kernel does the installer use?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core2 test3
2.Reboot
    

Actual Results:  As soon as it gets to the point of loading uhci_hcd
it finds my controller and then fails with "host controller halted,
very bad!"
The machine continues to boot, but I have no USB for keyboard or mouse.

Additional info:

USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:1d.0: UHCI Host Controller
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: irq 185, io base 00002000
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.0: host controller process error, something bad
happened!
uhci_hcd 0000:00:1d.0: host controller halted, very bad!
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected

It repeats this three times, for 1d.0, 1d.1, and 1d.2.


My machine is a Dual Processor Xeon 2.4 GHz machine with HT enabled. I
have 3GB of RAM, and an 80GB hard drive. I don't know the MOBO
offhand, but I can look it up with a reboot.
Comment 1 Pete Zaitcev 2004-05-10 17:38:13 EDT
Did you try to comment uhci_hcd from /etc/modprobe.conf
and add ehci-hcd ?
Comment 2 John F Meinel Jr 2004-05-10 20:17:49 EDT
It was already loading ehci_hcd, and when I disabled uhci_hcd the
keyboard and mouse still didn't work. The lights stayed on, so the USB
controller wasn't disabled, but there was no input. My guess is my USB
controller needs uhci_hcd (not ehci_hcd), but there is something
incorrect with the driver.
Comment 3 Pete Zaitcev 2004-05-10 21:10:02 EDT
More likely, driver is fighting with the BIOS.
Comment 4 John F Meinel Jr 2004-05-10 21:21:35 EDT
Well, I do have "Legacy USB" turned on in the BIOS, but that is the
only way that Grub will work. I suppose as an ugly workaround I could
have Fedora Core 2 be the default target, and if I want to boot
something else, I just switch my bios setting. 

Just to test it, I will do a reboot, but that's certainly not the
situation I would like to stick with.
Comment 5 John F Meinel Jr 2004-05-18 16:33:01 EDT
Well, I did the test, but without luck. Nothing I did allowed uhci_hcd
to load properly (and as I mentioned ehci_hcd doesn't support my USB
devices.)

Does anyone know the flags for uhci_hcd so that I can disable USB2 if
I have to?
Comment 6 John F Meinel Jr 2004-05-22 17:18:48 EDT
I was looking through some of the kernel logs, and I saw that in the
Changelog for 2.6.6 
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.6

And I saw that there were fixes for UHCI. Probably this is the
important one:
[PATCH] USB: Important bugfix for UHCI list management code

Anyway, I installed 2.6.6-bk8, and now UHCI loads fine and I have USB
support again.
Comment 7 Pete Zaitcev 2004-08-20 04:59:20 EDT
So, does 2.6.7-1.494.2.2 work? If yes, please close.
Comment 8 John F Meinel Jr 2004-09-11 11:52:15 EDT
I updated to the latest kernel available from Up2date (I think it was
still a 2.6.5 kernel).
And with that kernel, it had a kernel panic, rather than booting and
not allowing USB to run.

I didn't see a way to install 2.6.7-1.494.2.2, is it not Up2date, or
did I just miss something.

John
Comment 9 Dave Jones 2004-11-27 15:21:47 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 10 John F Meinel Jr 2005-02-07 12:55:48 EST
I went ahead and upgraded to FC3, and the problem seems to be fixed.

On FC2, I tried a couple of the up2date kernels, and none of them worked.
(Though they generally failed with a kernel panic, rather than running with USB
disabled.)

John
=:->
Comment 11 Pete Zaitcev 2005-02-07 15:45:10 EST
OK, I'm closing this.

P.S. If self-built kernels do not run, usually it's because something
was wrong with initrd: operator forgot to run mkinitrd, or other failure.
I use lots and lots of self-built kernels on FC2 & FC3.

Note You need to log in before you can comment on or make changes to this bug.