Bug 1229416 - Failed to start reboot.target: Access denied
Summary: Failed to start reboot.target: Access denied
Keywords:
Status: CLOSED DUPLICATE of bug 1224211
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-08 16:35 UTC by John Ellson
Modified: 2015-09-28 07:50 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-08 16:36:41 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1260223 None None None Never

Internal Links: 1260223

Description John Ellson 2015-06-08 16:35:11 UTC
Description of problem:
Some recent update is preventing root from rebooting.

From "strace repboot" its a result of a message "org.freedesktop.DBus.Err" from dbus.

It may be significant that the system is running without a desktop.
I had done: 
  systemctl disable graphical.target; system disable gdm.service
I can no longer use systemctl to reenable.

(Why isn't there a "no desktop" spin?)

Version-Release number of selected component (if applicable):
systemd-220-5.fc23.x86_64
polkit-0.112-9.fc22.x86_64
glibc-2.21.90-15.fc23.x86_64
kernel-4.1.0-0.rc6.git2.1.fc23.x86_64

How reproducible:
100%

Steps to Reproduce:
1.reboot
2.
3.

Actual results:
[root@fc23-64 ~]# reboot
Failed to start reboot.target: Access denied

Broadcast message from root@fc23-64 on pts/0 (Mon 2015-06-08 12:19:21 EDT):

The system is going down for reboot NOW!

[root@fc23-64 ~]#

Expected results:
reboot

Additional info:

Basically root cannot execute any systemctl command:

[root@fc23-64 ~]# systemctl -a
Failed to list units: Access denied
[root@fc23-64 ~]#

Comment 1 Zbigniew Jędrzejewski-Szmek 2015-06-08 16:36:41 UTC

*** This bug has been marked as a duplicate of bug 1224211 ***

Comment 2 fedorino-core 2015-09-17 20:49:47 UTC
The same bug for me! Fedora 22 (GNOME) :(

Comment 3 fedorino-core 2015-09-17 21:19:22 UTC
After doing Ctrl+Alt+Del 2 times I finally rebooted...

Comment 4 Thorsten Kohfeldt 2015-09-24 14:59:15 UTC
I found a workaround for the most recent problem in F22:

dnf -y distro-sync # this might create a systemd SELinux problem
if ! (systemctl list-sockets >/dev/null && systemctl list-dependencies >/dev/null)
then
  dnf -y reinstall systemd
  if systemctl list-sockets >/dev/null && systemctl list-dependencies >/dev/null
  then
    echo "Update-related systemd SELinux problem: FIXED"
  else
    echo "sorry, systemd still has SELinux trouble"
  fi
fi


i.e. just performing 'dnf -y reinstall systemd' solved it for me

Comment 5 Thorsten Kohfeldt 2015-09-24 17:25:47 UTC
And yes,

systemctl daemon-reexec

also works and is even faster ...

Comment 6 srakitnican 2015-09-25 09:26:20 UTC
F22 after dnf update not able to reboot. "systemctl daemon-reexec" fixed it.


Note You need to log in before you can comment on or make changes to this bug.