Bug 1229450 - conky configure still has incorrect lua configuration
Summary: conky configure still has incorrect lua configuration
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: conky
Version: epel7
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
: 1187743 (view as bug list)
Depends On:
Blocks: 1187095
TreeView+ depends on / blocked
Reported: 2015-06-08 19:52 UTC by Jonathan Billings
Modified: 2015-09-17 02:24 UTC (History)
3 users (show)

Fixed In Version: 1.9.0-16.20140617gitab826d.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-09-17 02:24:35 UTC

Attachments (Terms of Use)

Description Jonathan Billings 2015-06-08 19:52:03 UTC
Description of problem:
conky doesn't build with the current conky.spec file for epel7.  Currently, the spec file has this in the %prep section:

sed -i 's|lua == 5.1|lua = 5.1|g' configure.ac.in

If this is changed to:

sed -i 's|lua == 5.1|lua >= 5.1|g' configure.ac.in

... then the package builds fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Build against current spec file + sources

Actual results:
configure dies with:

checking for LUA51... configure: error: Package requirements (lua5.1 >= 5.1) were not met:

No package 'lua5.1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LUA51_CFLAGS
and LUA51_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Expected results:
configure to continue:

checking for LUA... yes

Additional info:
It looks like this fix was correctly applied to the fedora branch of the conky spec file, so this should be a fairly simple fix.

Comment 1 Miroslav Lichvar 2015-06-26 12:27:38 UTC
*** Bug 1187743 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Lichvar 2015-06-26 12:37:12 UTC
I'm not sure I follow. In Fedora 21 and later is lua-5.2, why should be this needed in EPEL7?

Comment 3 Jonathan Billings 2015-08-12 12:50:03 UTC
The version of LUA in RHEL7 and CentOS7 is 5.1.4.  Anyway, it doesn't matter if its 5.1 or 5.2.  The problem is that the configure.ac.in has a typo in it.

I'll repeat, in the conky.spec file:

sed -i 's|lua == 5.1|lua = 5.1|g' configure.ac.in

should be changed to:

sed -i 's|lua == 5.1|lua >= 5.1|g' configure.ac.in

Conky builds and runs fine on RHEL7 with that one minor change.

Comment 4 Miroslav Lichvar 2015-08-12 13:41:52 UTC
Ok, understood. Should be fixed in conky-1.9.0-16.20140617gitab826d.el7. Thanks.

Comment 5 Fedora Update System 2015-08-12 13:46:55 UTC
conky-1.9.0-16.20140617gitab826d.el7 has been submitted as an update for Fedora EPEL 7.

Comment 6 Fedora Update System 2015-08-13 20:23:08 UTC
conky-1.9.0-16.20140617gitab826d.el7 has been pushed to the Fedora EPEL 7 testing repository.

Comment 7 Fedora Update System 2015-09-17 02:24:34 UTC
conky-1.9.0-16.20140617gitab826d.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.