Bug 122962 - Wrong kernel headers in /usr/include/linux
Wrong kernel headers in /usr/include/linux
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-10 14:58 EDT by depeq
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 16:11:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description depeq 2004-05-10 14:58:27 EDT
Description of problem:
In /usr/include/linux directory there are includes for kernel 2.4.20
!! (look to the /usr/include/linux/version.h file) but the system
works on 2.6.5 kernel.
Comment 1 Arjan van de Ven 2004-05-10 16:11:03 EDT
those headers only describe the interface between the kernel and
userspace, the "version" is irrelevant and no app should use it; it
just needs to be there as "something".
Comment 2 depeq 2004-05-11 04:19:08 EDT
Maybe you're right but some programs need the file version.h to compile. 
They look for it in /usr/src/linux-x.y.z-*/include/linux but it isn't there so I 
thought that /usr/include/linux/version.h is the same. 
Maybe it's a bug in kernel-source package... 
If not - what should I do? - I can't compile my ADSL modem driver because I 
always get the message: 
"error: kernel-sources version is different from the current kernel!" 
hmm... 
 
Comment 3 Arjan van de Ven 2004-05-11 04:21:32 EDT
well kernel modules cnanot use /usr/include/<anything> really.
Sounds like a kernel module with a misdesigned makefile (eg what they
do may have worked in Red Hat Linux 6.2 but not afterwards).

I would recommend you to read the files in the Documentation/kbuild/
directory about how to build external kernel modules.

Note You need to log in before you can comment on or make changes to this bug.