Bug 1229658 - STACK_RESET may crash with concurrent statedump requests to a glusterfs process
Summary: STACK_RESET may crash with concurrent statedump requests to a glusterfs process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: krishnan parthasarathi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1234408
TreeView+ depends on / blocked
 
Reported: 2015-06-09 11:10 UTC by krishnan parthasarathi
Modified: 2016-06-16 13:10 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1234408 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:10:07 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description krishnan parthasarathi 2015-06-09 11:10:23 UTC
Description of problem:
statedump requests that traverse call frames of all call stacks in execution may race with a STACK_RESET on a stack. This could crash the corresponding glusterfs process. For e.g, recently we observed this in a regression test case, tests/basic/afr/sparse-self-heal.t.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Intermittent

Steps to Reproduce:
1. Maintain constant I/O on a GlusterFS volume.
2. Issue a statedump request, using kill -SIGUSR1 <process-pid> concurrently.
3.

Actual results:
glusterfs process may crash

Expected results:
glusterfs process shouldn't crash and the statedump must be logged successfully.

Additional info:

Comment 1 Anand Avati 2015-06-09 11:43:20 UTC
REVIEW: http://review.gluster.org/11095 (stack: use list_head for managing frames) posted (#5) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 2 Nagaprasad Sathyanarayana 2015-10-25 15:23:09 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 3 Niels de Vos 2016-06-16 13:10:07 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.