Bug 1229796 - DRAC ready-state configuration doesn't exist in the CLI
Summary: DRAC ready-state configuration doesn't exist in the CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Imre Farkas
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1233969 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-09 15:57 UTC by Imre Farkas
Modified: 2016-09-20 05:03 UTC (History)
8 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-3.el7ost
Doc Type: Bug Fix
Doc Text:
The DRAC ready-state configuration was not implemented in the unified CLI, it was implemented only in the deprecated OpenStack Deployment (tripleO) scripts. As a result, the command was missing from python-rdomanager-oscplugin. With this update, the DRAC ready-state is implemented and 'openstack baremetal configure ready state' command is now present in the CLI.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:53:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Imre Farkas 2015-06-09 15:57:28 UTC
Description of problem:
DRAC ready-state configuration doesn't exist in the CLI, it's only in instack scripts.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Imre Farkas 2015-06-16 14:54:37 UTC
Patch posted midstream: https://review.gerrithub.io/#/c/236648/

Comment 7 Mike Burns 2015-06-20 00:43:12 UTC
*** Bug 1233969 has been marked as a duplicate of this bug. ***

Comment 9 Alexander Chuzhoy 2015-07-20 14:05:17 UTC
Verified:
Environment:
instack-undercloud-2.1.2-21.el7ost.noarch

The command "openstack baremetal configure ready state" is present now.

Upon execution, prompted "Waiting for discovery to finish" and then I got the prompt back.

Comment 11 errata-xmlrpc 2015-08-05 13:53:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.