Bug 122981 - Display errors
Display errors
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-05-10 18:37 EDT by tony issacs
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-12 03:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description tony issacs 2004-05-10 18:37:23 EDT
Description of problem:
I can't edit or change my display functions. My display is stuck
at a rather horrible 640X480.  I usually set mine at 800 or even
smaller, better resolution.  Fedora detects my video card as an ATI
Radeon 9000. Mine is an ATI Radeon 9000 Pro. This is a list among
choices to change it to. I change the vid settings to my 9000 Pro. I
then recieve an option to change the resolution to the better
resolution choice. HOwever when I make the changes, they are NOT
saved. IT WILL NOT save the changes and returns to the default.  
Before I go on, I'd like to say that I have tried this logged into
root and Su'd in as well. It makes no difference.  It doesn't write
the chnages.  I also exit X windows, as it tells you to do so. I
always reset my runlevel to 3 so that it boots auto into the command
line...So this is also not an issue. I'm at a loss. Nothing seems to
work. It appears that it's just not compatible with my system.  Any ideas?
The package itself looks quite impressive, if I could just resolve the 
Display issue.  Everything is WAYYYYYY to large. :-)
Any and all thoughts would be most appreciated.


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Ed Bailey 2004-05-10 21:34:54 EDT
Changing to correct component.
Comment 2 tony issacs 2004-05-11 18:11:02 EDT
I resolved this bug error by the following steps:
It does not install the correct video settings and you can not save
any video settings. It defaults to the lower resolution of 480X600 and
you can't change it. It defaults to the wrong video card: ATI Radeon
9000, instead of the ATI Radeon 9000 Pro. It also defaults to the
wrong monitor settings.  All of these are fixable by manually editing
the XF86Config file> I had to manually go throug via the command line
edit the XF86Config file and put in the correct vid card and the
correct monitor specs. I also had to manually add the correct
resolution in order to resolve this issue.
I am also including a list of other bugs that I found in the product:
In addition the the previous bug, These bugs were also noticed:
2.Mplayer does not play DVD's with the new kernal.  It gives an error
stating that /dev/dvd can't be opened.
3.The sound recorder doesn't run. It crashes crashes when you attempt
to record. I will try it with Gnome, the defaulted desktop and see if
it works. It may be a KDE issue.
4.Open office Writer and Spreadsheet  are opening duplicates when
opening a single document.
5.KDE crashes when trying to copy files from cd devices to the home
directory.  Once the crashes occur than you must delete the file from
the home directory that was being copied when the crash occurred. You
can not simply overwrite the files. devices that crashed are:
/dev/cdrom1 and /dev/cdrom.
6, The sound card crashed in KDE and It will not function at the
moment.  To resolve this issue, I would need to remove the sound
driver and reinstall it manually. Unfortunatly this Beta is too buggy
for me or my system so I will be going back to the original Fedora,
which worked fine. I just wanted to put this on the bug list for
others edification.
Comment 4 Mike A. Harris 2004-10-12 03:13:00 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:


If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.