Bug 122984 - XIO fatal IO error 104 when mouse moved
XIO fatal IO error 104 when mouse moved
Status: CLOSED DUPLICATE of bug 108777
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-10 19:41 EDT by insaner
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description insaner 2004-05-10 19:41:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
during install (tested from cd images on harddrive) once x begins to
load, (after detecting (correctly) my matrox millenium g400, followed
by my compaq p900 monitor and my generic 3button mouse ps/2) moving
the mouse before the "fedora" image appears, causes the x server to
die, and the installation to abort:

----
XIO fatal IO error 104 (connection reset by peer) on X server ":1.0"
after 0 requests (0 unkown processes) with 0 events remaining
install exited abnormally
----



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.wait for x server to detect my hardware (upto mouse)
2.move mouse (before x server has loaded the "fedora" image/logo)
3.
    

Actual Results:  the x server died with:


----
XIO fatal IO error 104 (connection reset by peer) on X server ":1.0"
after 0 requests (0 unkown processes) with 0 events remaining
install exited abnormally
----

and then the installation aborted

Expected Results:  the cursor should have moved, and x server should
have loaded properly, and installation should have not failed

Additional info:
Comment 1 Amitabha 2004-05-19 11:25:55 EDT
Same error happens when installing Fedora Core 2 on a Pentium 4,
Geforce MX 4 (generic) Dall desktop.

OPtion chosen: 
install from hard disk.

As soon as mouse is moved on detection of PS/2 mouse, anaconda quits.

Goes through if the mouse if not moved.

Same exact XIO error. 
Comment 2 Jeremy Katz 2004-09-22 15:47:08 EDT

*** This bug has been marked as a duplicate of 108777 ***
Comment 3 Ian Posner 2005-07-06 18:46:10 EDT
Fatal error occurs even if the mouse is removed from the PS/2 socket prior to 
booting! No mouse is detected and then the installer asks to choose a mouse. 
Choosing the "no mouse" option and pressing OK for the graphical install still 
causes the crash after the xserver is loaded. Using an old Riva 128 AGP 
graphics card.
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.