Bug 1229895 - Enable NetApp Backends in Cinder
Summary: Enable NetApp Backends in Cinder
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Jay Dobies
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-09 21:16 UTC by Ryan Hefner
Modified: 2015-08-05 13:53 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-45.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:53:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 187700 None None None Never
OpenStack gerrit 193143 None None None Never
OpenStack gerrit 193627 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ryan Hefner 2015-06-09 21:16:22 UTC
Description of problem:

Enables support for configuring Cinder with a NetApp backend.
This change adds all relevant parameters for:
 - Clustered Data ONTAP (NFS, iSCSI, FC)
 - Data ONTAP 7-Mode (NFS, iSCSI, FC)
 - E-Series (iSCSI)

The NetApp team is handling the QA for the above patch (see Gerrit link).

Version-Release number of selected component (if applicable):
master

How reproducible:
Always

Steps to Reproduce:
1. Start a deployment
2. Configure NetApp Cinder parameters
3.

Actual results:
Does not configure NetApp Cinder backend

Expected results:
Successfully configures NetApp Cinder backend

Additional info:

Comment 3 Mike Orazi 2015-06-09 22:02:58 UTC
https://review.openstack.org/#/c/187700/

Comment 6 Ryan Hefner 2015-06-19 19:33:37 UTC
Verified that this is functioning with the following minor Puppet patch:
https://review.openstack.org/#/c/193627/

The deployment contains a valid cinder.conf with the tripleo_netapp stanza and all of the required parameters valid. Thanks for Steve Hardy with devising a new method yesterday for handling the service backend deployments.

Comment 7 Mike Burns 2015-06-19 19:41:34 UTC
moving back to assigned to track the new patch

Comment 9 Jay Dobies 2015-07-06 14:07:38 UTC
This needs the following patches:

THT changes to support pre-deploy hooks:
https://review.openstack.org/#/c/193143/

NetApp enablement:
https://review.openstack.org/#/c/193627/

Comment 14 errata-xmlrpc 2015-08-05 13:53:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.