Bug 1229896 - [RFE] Deploy Manila in OSP director with HA
Summary: [RFE] Deploy Manila in OSP director with HA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Marios Andreou
QA Contact: Dustin Schoenbrun
Don Domingo
URL:
Whiteboard:
Depends On: 1298044 1379905
Blocks: 1335593
TreeView+ depends on / blocked
 
Reported: 2015-06-09 21:20 UTC by Ryan Hefner
Modified: 2016-12-14 15:10 UTC (History)
22 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160922100830.75c20d5.1.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:10:51 UTC
scohen: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 188137 None None None Never
OpenStack gerrit 313527 None None None 2016-05-19 18:46:59 UTC
OpenStack gerrit 315658 None None None 2016-05-19 17:20:01 UTC
Red Hat Bugzilla 1298044 None None None Never

Internal Links: 1298044

Description Ryan Hefner 2015-06-09 21:20:03 UTC
Description of problem:
Allows the installation and configuration of Manila.
Supports the generic driver and the NetApp driver.

The NetApp team is handling the QA for the above patch (see Gerrit link).

#link Manila generic driver: https://review.openstack.org/#/c/188137/
#link Manila NetApp driver: https://review.openstack.org/#/c/188138/

Version-Release number of selected component (if applicable):
master

How reproducible:
Always

Steps to Reproduce:
1. Enable Manila and configure parameters
2. Start the deployment
3.

Actual results:
Manila does not configure

Expected results:
Manila is successfully configured and enabled

Additional info:

Comment 3 Marios Andreou 2015-06-17 12:15:25 UTC
Hi Ryan, I see that both of those are still in review so I assume you've patched your env for the deploy with those reviews? How are you deploying (I mean are you using tuskar) and do the defaults in the templates give a working vanilla setup (or should at least?) or do I need to be aware of something specific.

Comment 4 Ryan Hefner 2015-06-19 19:38:22 UTC
Hi marios, sorry I didn't see your message before. I'm using instack-deploy-overcloud --tuskar and tweaking the outputted Tuskar templates as necessary for quick testing.  As far as a valid deployment, you'll need to specify a valid netapp_login, netapp_password and netapp_server_hostname.

You don't need to actually deploy to and use a NetApp storage system - as long as there is a valid cinder.conf stanza, that should be good enough to get it going.

I tested this patch:
https://review.openstack.org/#/c/188137/

and get a valid deployment with Manila present. Going to drop the NetApp patch in shortly and see if I can get that rolling.

Comment 17 Hugh Brock 2016-02-03 14:26:16 UTC
RFEs are in no case ever blockers. I have removed the blocker flag.

Comment 18 Dave Cain 2016-05-19 17:20:02 UTC
Adding https://review.openstack.org/#/c/315658/.

Comment 19 Sean Cohen 2016-08-03 16:25:46 UTC
https://review.openstack.org/#/c/188137/ has been merged upstream

Comment 20 Tom Barron 2016-08-05 15:25:12 UTC
https://review.openstack.org/#/c/313527/ also merged upstream

https://review.openstack.org/#/c/315658/ was I think incorporated into https://review.openstack.org/#/c/188137/ but it hasn't yet been abandoned

Ben Swartzlander (bswarz) from NetApp is going to propose a new version of the NetApp plugin patch - we'll add it to the external trackers when he posts it.

Comment 25 Dustin Schoenbrun 2016-11-21 15:57:24 UTC
Tested with the 2016-11-11.1 puddle and the Manila Share service is successfully started on another controller node when it is disabled on the Active node and the Scheduler and API services still function when they're disabled on one node.

Comment 27 errata-xmlrpc 2016-12-14 15:10:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.