Bug 122997 - X login failed when user shell is /bin/tcsh
X login failed when user shell is /bin/tcsh
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 03:59 EDT by Sébastien Pierre
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 03:15:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sébastien Pierre 2004-05-11 03:59:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506

Description of problem:
When I switched my user shell from /bin/bash to /bin/tcsh, I was not
able to log in after the gdm invite.

Changing back my shell from tcsh to bash worked properly. I guess that
there is a missing shebang (#!/bin/bash) in some X init scripts.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Change user shell to /bin/tcsh
2. Log out
3. Log in
    

Actual Results:  An error message regarding X init scripts

Expected Results:  Proper log in

Additional info:
Comment 1 Mike A. Harris 2004-10-12 03:15:33 EDT
There have been many changes to Fedora Core since this bug was filed,
which might resolve this issue.  Please upgrade to Fedora Core 2
or later, and if this problem still persists, please reopen the
bug, and provide any new details.  Also be sure to cut and paste
the exact text of any errors your receive, and where you are
seeing the error.

Thanks in advance.

Setting status to "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.