Bug 1229991 - memory corruption when no fonts installed
Summary: memory corruption when no fonts installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tk
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-10 05:43 UTC by Akira TAGOH
Modified: 2015-07-14 15:41 UTC (History)
1 user (show)

Fixed In Version: tk-8.6.4-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-14 15:41:46 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
patch to fix this issue (402 bytes, patch)
2015-06-10 05:43 UTC, Akira TAGOH
no flags Details | Diff

Description Akira TAGOH 2015-06-10 05:43:29 UTC
Created attachment 1037098 [details]
patch to fix this issue

Description of problem:
tk application crashes when no fonts installed due to bad handling of fontconfig related code.

Version-Release number of selected component (if applicable):
tk-8.6.4-1.fc22

How reproducible:
always

Steps to Reproduce:
1.remove all of fonts package if installed
2.run gitk say
3.

Actual results:
segfault

Expected results:
no segfault

Additional info:
backtrace says it crashes in fontconfig but it happened due to giving memory-corrupted pointer to it. so the real problem is in tk.

Comment 1 Jaroslav Škarvada 2015-07-02 15:52:04 UTC
(In reply to Akira TAGOH from comment #0)
Thanks applied.

Comment 2 Fedora Update System 2015-07-02 16:18:19 UTC
tk-8.6.4-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/tk-8.6.4-2.fc22

Comment 3 Fedora Update System 2015-07-03 18:49:08 UTC
Package tk-8.6.4-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tk-8.6.4-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11119/tk-8.6.4-2.fc22
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-07-14 15:41:46 UTC
tk-8.6.4-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.