Bug 12300 - redundant prereq in glibc spec file
Summary: redundant prereq in glibc spec file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-15 14:36 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-15 16:03:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-06-15 14:36:02 UTC
The spec file for glibc-2.1.90-17 contains:

Prereq: kernel-headers
Requires: kernel-headers >= 2.2.1

Isn't this redundant?  That is, doesn't the second line imply the first, in
which case the first should be removed?

Comment 1 Bill Nottingham 2000-06-15 16:03:15 UTC
I believe it's there in that you can't prereq a particular
*version* of a package.

Comment 2 Jakub Jelinek 2000-08-25 16:16:38 UTC
No, the second line does not imply the first, Prereq means that kernel-headers
must be installed already at the time glibc-devel is being installed, as opposed
to Requires which means the requirement can be fulfilled within the same transaction set.


Note You need to log in before you can comment on or make changes to this bug.