Bug 1230035 - systemd: AVC denials for all DBus calls
Summary: systemd: AVC denials for all DBus calls
Keywords:
Status: CLOSED DUPLICATE of bug 1224211
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-10 07:31 UTC by Jakub Filak
Modified: 2016-12-01 00:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-10 07:46:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Jakub Filak 2015-06-10 07:31:55 UTC
Since systemd-220, any time I run systemctl or any other tool calling systemd DBus methods I get 'Failed to get properties: Access denied' and a new AVC appears in journal.

# id -a
uid=0(root) gid=0(root) groups=0(root) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
# systemctl status abrtd
Failed to get properties: Access denied
# systemctl isolate graphical.target
Failed to start graphical.target: Access denied
# systemd-analyze dot
Failed to list units: Access denied



Additional info:
Jun 10 09:27:26 fedora-rawhide systemd[1]: Accepted new private connection.
Jun 10 09:27:26 fedora-rawhide systemd[1]: systemd-journald.service: Got notification message from PID 457 (WATCHDOG=1)
Jun 10 09:27:26 fedora-rawhide systemd[1]: Got message type=method_call sender=n/a destination=org.freedesktop.systemd1 object=/org/freedesktop/systemd1/unit/abrtd_2eservice interface=org.f
Jun 10 09:27:26 fedora-rawhide systemd[1]: abrtd.service: Failed to load configuration: No such file or directory
Jun 10 09:27:26 fedora-rawhide audit[1]: USER_AVC pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { status } for auid=1000 uid=0 gid=0 cmdline
                                          exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
Jun 10 09:27:26 fedora-rawhide systemd[1]: SELinux access check scon=system_u:object_r:unlabeled_t:s0 tcon=system_u:system_r:init_t:s0 tclass=system perm=status path=(null) cmdline=systemct
Jun 10 09:27:26 fedora-rawhide systemd[1]: Sent message type=error sender=n/a destination=n/a object=n/a interface=n/a member=n/a cookie=1 reply_cookie=1 error=SELinux policy denies access.
Jun 10 09:27:26 fedora-rawhide systemd[1]: Failed to process message [type=method_call sender=n/a path=/org/freedesktop/systemd1/unit/abrtd_2eservice interface=org.freedesktop.DBus.Properti
Jun 10 09:27:26 fedora-rawhide systemd[1]: abrtd.service: Collecting.
Jun 10 09:27:26 fedora-rawhide systemd[1]: Sent message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1 interface=org.freedesktop.systemd1.Manager member=UnitNew coo
Jun 10 09:27:26 fedora-rawhide systemd[1]: abrtd.service: Failed to send unit change signal for abrtd.service: Connection reset by peer
Jun 10 09:27:26 fedora-rawhide systemd[1]: Sent message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1 interface=org.freedesktop.systemd1.Manager member=UnitRemoved
Jun 10 09:27:26 fedora-rawhide systemd[1]: abrtd.service: Failed to send unit remove signal for abrtd.service: Transport endpoint is not connected
Jun 10 09:27:26 fedora-rawhide systemd[1]: Got disconnect on private connection.

Comment 1 Jakub Filak 2015-06-10 07:46:40 UTC

*** This bug has been marked as a duplicate of bug 1224211 ***


Note You need to log in before you can comment on or make changes to this bug.