Bug 1230167 - [Snapshot] Python crashes with trace back notification when shared storage is unmount from Storage Node
Summary: [Snapshot] Python crashes with trace back notification when shared storage is...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: Scheduler
Depends On: 1228164 1228613
Blocks: 1223636
TreeView+ depends on / blocked
 
Reported: 2015-06-10 11:45 UTC by Avra Sengupta
Modified: 2015-07-10 05:36 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1228613
Environment:
Last Closed: 2015-06-20 09:50:30 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-10 11:47:10 UTC
REVIEW: http://review.gluster.org/11159 (snapshot/scheduler: Check if GCRON_TASKS exists before accessing it's mtime) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-06-10 19:59:19 UTC
REVIEW: http://review.gluster.org/11159 (snapshot/scheduler: Check if GCRON_TASKS exists before accessing it's mtime) posted (#2) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-06-11 11:50:38 UTC
COMMIT: http://review.gluster.org/11159 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 04722f44fd05ce8b247e18034c1e261a7734a827
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Tue Jun 9 17:49:23 2015 +0530

    snapshot/scheduler: Check if GCRON_TASKS exists before
    accessing it's mtime
    
         Backport of http://review.gluster.org/#/c/11138/
    
    Change-Id: I873c83d21620527b20d7de428d11582c5499d1af
    BUG: 1230167
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    (cherry picked from commit 5b05d3e376e984f00528f5bf2f0febd0220ca91f)
    Reviewed-on: http://review.gluster.org/11159
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 4 Niels de Vos 2015-06-20 09:50:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.