Bug 1230169 - afr: dereference of a null pointer
Summary: afr: dereference of a null pointer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-10 11:50 UTC by Prasanna Kumar Kalever
Modified: 2018-08-29 03:37 UTC (History)
2 users (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:37:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2015-06-10 11:50:15 UTC
Description of problem:
 Access to field 'lock_piggyback' results in a dereference of a null
 pointer (loaded from variable 'fd_ctx')


Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-06-10 11:59:02 UTC
REVIEW: http://review.gluster.org/11160 (afr: dereference of a null pointer) posted (#1) for review on master by Prasanna Kumar Kalever

Comment 2 Anand Avati 2015-06-10 12:14:07 UTC
REVIEW: http://review.gluster.org/11160 (afr: dereference of a null pointer) posted (#2) for review on master by Prasanna Kumar Kalever

Comment 3 Anand Avati 2015-06-17 06:27:36 UTC
REVIEW: http://review.gluster.org/11160 (afr: dereference of a null pointer) posted (#3) for review on master by Prasanna Kumar Kalever

Comment 4 Anand Avati 2015-06-23 06:35:31 UTC
REVIEW: http://review.gluster.org/11160 (afr: dereference of a null pointer) posted (#4) for review on master by Prasanna Kumar Kalever

Comment 5 Anand Avati 2015-07-14 09:09:37 UTC
REVIEW: http://review.gluster.org/11160 (afr: dereference of a null pointer) posted (#5) for review on master by Prasanna Kumar Kalever

Comment 6 Anand Avati 2015-07-14 12:09:34 UTC
REVIEW: http://review.gluster.org/11160 (afr: dereference of a null pointer) posted (#6) for review on master by Prasanna Kumar Kalever

Comment 7 Mike McCune 2016-03-28 23:22:56 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 8 Amar Tumballi 2018-08-29 03:37:14 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.