Bug 123018 - [patch] .xls files don't open under recent documents
[patch] .xls files don't open under recent documents
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 07:45 EDT by G O
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 08:23:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ooo patch (9.30 KB, patch)
2004-11-09 03:34 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description G O 2004-05-11 07:45:02 EDT
Description of problem:

Launching an .xls file from the RedHatIcon-RecentDocuments list
doesn't work.  

Version-Release number of selected component (if applicable):

fc2 t3 - default install

How reproducible:

every time

Steps to Reproduce:
1. see description above
2.
3.
  
Actual results:

The error is "couldn't find suitable application".  However using
Nautilus there is no problem.  

Expected results:

File should opens just like it does in nautilus.

Since it works with nautilus (safe assumption that it is always there)
this is a bug with the way Recent Docs are handled.  Seems like a no
brainer requirement for any desktop deployment - it should work out of
the box - i shouldn't have to adjust config files.


Additional info:
Comment 1 Alexander Larsson 2004-10-05 08:03:56 EDT
Still seems to happen in fc3test3.
Comment 2 Mark McLoughlin 2004-10-07 05:50:19 EDT
Looks like an OpenOffice bug - its setting an empty <MimeType> in
~/.recently-used when you save an xls

(I'll open an upstream bug against recent-files to make it more robust
against applications which do this, though.)
Comment 3 Mark McLoughlin 2004-10-07 06:33:55 EDT
Upstream patch to make recent-files more robust:

  http://bugzilla.gnome.org/show_bug.cgi?id=154765
Comment 4 Caolan McNamara 2004-11-09 03:34:31 EST
Created attachment 106315 [details]
ooo patch

Patch to OOo (well ooo-build extension to OOo) to not write a recent file entry
without a mime-type. And more usefully add the excel mime-types into the excel
filter detection.xcu so that ooo will be launched from selecting excel entries
from recenly-used entries written by OOo.
Comment 5 Caolan McNamara 2004-11-09 04:18:37 EST
mime-types 2.0 upstream patch at
http://www.openoffice.org/issues/show_bug.cgi?id=36890
Comment 7 GO 2005-01-18 19:54:40 EST
No news on this since mid Nov and that patch doesn't look like it's
going to get much attention.  What the heck do txt files have to do
with this anyway?

The bottom line is that FC3 still does not open .xls files properly
under Recent Documents.  An ugly fix would be better than no fix.
Comment 8 Caolan McNamara 2005-01-27 08:23:46 EST
1.1.3 is now in FC3 and rawhide, should fix this.
Comment 9 GO 2005-01-28 08:39:35 EST
Thanks. OOo 1.1.3-2.5.fc3 fixes this.  But you've got to open your
file the standard way first to overwrite the state.

Note You need to log in before you can comment on or make changes to this bug.