Bug 1230196 - BareMetal/node show info is huge and unreadable same for ironic client
Summary: BareMetal/node show info is huge and unreadable same for ironic client
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ironicclient
Version: Director
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: Director
Assignee: RHOS Maint
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-10 12:23 UTC by Ofer Blaut
Modified: 2015-08-05 13:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:53:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
output (838 bytes, text/plain)
2015-06-10 12:23 UTC, Ofer Blaut
no flags Details
ironic node-show result (58.31 KB, text/plain)
2015-06-10 13:50 UTC, Ofer Blaut
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ofer Blaut 2015-06-10 12:23:06 UTC
Created attachment 1037258 [details]
output

Description of problem:

I have tried to discover hosts and one of them failed.

Tried to look on the BM info and the output is not readable 

Version-Release number of selected component (if applicable):



How reproducible:


Steps to Reproduce:
After instack-ironic-deployment --discover-nodes

1.openstack baremetal list
2.openstack baremetal show <ID> 
3.

Actual results:

output is not readable  using openstack baremetal show <ID >
but works ok with ironic node-show <ID> 


Expected results:


Additional info:

Comment 1 Ofer Blaut 2015-06-10 13:50:37 UTC
Created attachment 1037307 [details]
ironic node-show result

Comment 2 Mike Burns 2015-06-22 18:29:09 UTC
This is fixed by the fix for bug 1227755

Comment 4 Omri Hochman 2015-06-23 15:46:09 UTC
Verified RHEL-OSP director puddle 7.0 RC - 2015-06-22.1


| extra                  | {u'newly_discovered': u'true', u'block_devices': {u'serials': [u'QM00005']}, u'hardware_swift_object': u'extra_hardware-0435427e-5839-4618-a673-2543a1463d36'}

Comment 6 errata-xmlrpc 2015-08-05 13:53:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.