Bug 123023 - fedora-release missing on PPC
fedora-release missing on PPC
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-05-11 09:31 EDT by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 15:05:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2004-05-11 09:31:23 EDT
Description of problem:
The fedora-release package no longer exists in rawhide.

Version-Release number of selected component (if applicable):
Last seen was 1.91-8 but that now seems to have disappeared even from
internal archives. Neither can I find fedora-release in CVS.

The only difference between different arch builds of fedora-release
seems to be the release notes -- any they contain the arch name in
their filename anyway. Is there any particular reason we couldn't ship
fedora-release as a noarch package containing notes for _all_
architectures? After all, the time I most care about release notes for
some new architecture is before I've managed to get the beast
installed, so I'm most likely to want PPC and x86_64 release notes on
my i386 box, right?

Failing that, couldn't it at least be built from the same tarball,
with %ifarch in the spec file to select which release notes to
include? Currently we seem to have a separate source RPM for each
separate architecture.
Comment 1 Ed Bailey 2004-05-11 11:56:48 EDT
I'll address the documentation aspect of this, and then reassign to
Elliot, as he is responsible for the mechanics of actually getting the
packages built.

As for multi-arch release notes, the first thing to keep in mind is
that the only arches that currently have *any* content in the release
notes are x86 and x86_64.  So there's no PPC-specific content you're
missing, because there's no PPC-specific content at all... :-)

Over and above that, for the vast majority of people, they'll only
find the release notes for their arch relevant (if they even *read*
the release notes -- but that's another issue entirely).

Besides, one could argue that before installing on some new arch, you
must first have access to the bits for that new arch.  And since those
bits also contain the release notes, you will have them when you need
them... :-)

Elliot -- I'll leave the package-specific aspects of this to you...
Comment 2 Elliot Lee 2004-05-13 15:05:30 EDT
I believe this is fixed now with the fedora-release-2-rawhide package

Note You need to log in before you can comment on or make changes to this bug.