This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 123034 - Using nicknames causes problems with dhclient-script
Using nicknames causes problems with dhclient-script
Status: CLOSED DUPLICATE of bug 124022
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 12:28 EDT by Orion Poplawski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2004-05-11 12:28:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
I've created two wireless device configurations that use the same
hardware device ("eth2"), one with a specified SSID and key, and one
without.

I want to call one "CoRAwlan" and the other "wlan" using nicknames. 
However, once I've done that, when I activate the network I get the
following output:

Determining IP information for eth2.../sbin/dhclient-script:
configuration for eth2 not found.
/sbin/dhclient-script: configuration for eth2 not found.
/sbin/dhclient-script: configuration for eth2 not found.
/sbin/dhclient-script: configuration for eth2 not found.

and this repeats forever, though the interface does come up okay.

Another note - when adding a second "interface" to a wireless device,
I don't think it should set the device alias to "1" (or anything).

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
    

Additional info:
Comment 1 Marecandja 2004-05-24 05:28:11 EDT
This bug is reproducable on Core 2 as well.

The problem is that dhclient will execute dhclient-script which will
execute a method (need_config) from the script
/etc/sysconfig/network-scripts/network-functions. The problem is,
dhclient works with the real interface name (eg ethx, etc...) while if
you use nicknames, the config files will be renamed ifcfg-<nickname>.
Thus, when the method need_config is passed the real name of the
interface to setup, it will try to find the config file ifcfg-ethx and
won't find it...
Comment 2 Miloslav Trmac 2004-07-05 13:54:46 EDT

*** This bug has been marked as a duplicate of 124022 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.