Bug 1230346 - dnf terse error message "conflicting requests" not helpful
Summary: dnf terse error message "conflicting requests" not helpful
Keywords:
Status: CLOSED DUPLICATE of bug 1191611
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-10 17:06 UTC by Christopher Beland
Modified: 2015-07-24 12:35 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-24 12:35:08 UTC


Attachments (Terms of Use)
Full data on run with --debugsolver (5.59 MB, application/zip)
2015-06-10 17:06 UTC, Christopher Beland
no flags Details

Description Christopher Beland 2015-06-10 17:06:43 UTC
Created attachment 1037368 [details]
Full data on run with --debugsolver

With dnf-1.0.0-1.fc22.noarch I tried to install an older kernel from files I manually downloaded, because I need to run a kernel module not available for the latest kernel yet:

beland@localhost ~]$ sudo dnf install ./kernel-4.0.2-300.fc22.x86_64.rpm ./kernel-modules-4.0.2-300.fc22.x86_64.rpm ./kernel-core-4.0.2-300.fc22.x86_64.rpm 
Last metadata expiration check performed 2:03:17 ago on Wed Jun 10 10:55:20 2015.
Error: conflicting requests.
conflicting requests

The message "conflicting requests" does not provide enough information for me to solve the problem.  What is conflicting with what?

I currently have the following installed:

kernel-4.0.4-303.fc22.x86_64
kernel-core-4.0.3-300.fc22.x86_64
kernel-core-4.0.4-301.fc22.x86_64
kernel-core-4.0.4-303.fc22.x86_64
kernel-debug-devel-4.0.4-303.fc22.x86_64
kernel-headers-4.0.4-303.fc22.x86_64
kernel-modules-4.0.3-300.fc22.x86_64
kernel-modules-4.0.4-301.fc22.x86_64
kernel-modules-4.0.4-303.fc22.x86_64

When I re-ran with --debugsolver, I got the following in solver.result:

install kernel-4.0.2-300.fc22.x86_64@@commandline
install kernel-core-4.0.2-300.fc22.x86_64@@commandline
install kernel-modules-4.0.2-300.fc22.x86_64@@commandline
problem 3e63cf64 info conflicting requests
problem 3e63cf64 solution 685d72df deljob erase pkg kernel-core-4.0.2-300.fc22.x86_64@@commandline
problem 3e63cf64 solution ef4b0625 deljob install pkg kernel-4.0.2-300.fc22.x86_64@@commandline
problem 3e63cf64 solution ef4b0625 deljob install pkg kernel-core-4.0.2-300.fc22.x86_64@@commandline
problem d9841380 info conflicting requests
problem d9841380 solution 34974340 deljob erase pkg kernel-modules-4.0.2-300.fc22.x86_64@@commandline
problem d9841380 solution b7b737c4 deljob install pkg kernel-4.0.2-300.fc22.x86_64@@commandline
problem d9841380 solution b7b737c4 deljob install pkg kernel-modules-4.0.2-300.fc22.x86_64@@commandline

Comment 1 Peter Hutterer 2015-07-02 00:45:52 UTC
just ran into the same issue, increasing /etc/dnf/dnf.conf's installonly_limit fixed it

Comment 2 Michael Lipp 2015-07-16 10:15:18 UTC
I just ran into this. Although searching the web led to this bug (and the solution) in a quite straightforward way, a better error message would really, really be helpful!

Comment 3 Honza Silhan 2015-07-24 12:35:08 UTC

*** This bug has been marked as a duplicate of bug 1191611 ***


Note You need to log in before you can comment on or make changes to this bug.